Topaz and deepemhancer not working in version 4.1.2

Just updated to the latest version 4.1.2. Both topaz and deepemchaner do not work. See below for an example of an error. Let me know if you need any additional information.

Unable to queue P78 J268: ServerError: Failed to enqueue P78 J268 (topaz_train): Job has builder errors. Path to Topaz executable: Invalid path specified: /home/cryosparc/bin/ directory allowed: False; file allowed: True; glob allowed: False

Pease can you provide additional details:

  1. Under which CryoSPARC version have topaz jobs last worked on this CryoSPARC instance?
  2. With CryoSPARC running, please execute these commands (under the Linux account that runs CryoSPARC)
    ps xuww | grep supervisor
    stat /home/cryosparc/bin/

@wtempel Sorry. I just realized it is not due to cryosparc version issue. But rather due to this project was imported from another machine and it seems to have been set to “/home/cryosparc/bin/” for topaz script, which is different from the current machine. Despite I changed the path in the job, it still go for this project-level parameter. I tried to remove this setting from the project-level parameters tab. But it does not help.

Were you able to disable the project-level setting?
What is the error you are seeing now?
Were you able to set a job-level path to the topaz script?
What is the output of

ps xuww | grep supervisor
stat /path/to/topaz-script # job-level definition


Hi, we also have this issue with DeepEMhancer in v4.1.2. Trying to queue the job led to the similar error message (I am curious why the error message complains about the script while I was trying to run a DeepEMhancer job):
Unable to queue P7 J182: ServerError: Failed to enqueue P7 J182 (deepemhancer): Job has builder errors. Path to deepEMhancer executable: Invalid path specified: /home/yangyang/Applications/cryoem_tools/ directory allowed: False; file allowed: True; glob allowed: False
However, DeepEMhancer ran successfully in another Project that does not have project-level setting for Topaz and DeepEMhancer. In addition, resetting the project-level setting fort the problematic project did not solve the issue.
Here is the output of ps xuww | grep supervisor:

yangyang  718771  0.0  0.0  50096 10112 ?        Ss   Feb21   0:25 python /home/yangyang/Applications/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/bin/supervisord -c /home/yangyang/Applications/cryosparc/cryosparc_master/supervisord.conf
yangyang 1796278  0.0  0.0  17868  2424 pts/1    S+   04:57   0:00 grep --color=auto supervisor

Output of stat /home/yangyang/Applications/cryoEM_tools/

  File: /home/yangyang/Applications/cryoEM_tools/
  Size: 521       	Blocks: 8          IO Block: 4096   regular file
Device: 10305h/66309d	Inode: 44818688    Links: 1
Access: (0775/-rwxrwxr-x)  Uid: ( 1000/yangyang)   Gid: ( 1000/yangyang)
Access: 2023-02-22 00:57:48.104234973 -0600
Modify: 2023-02-18 00:17:43.762822316 -0600
Change: 2023-02-18 00:28:17.471878237 -0600
 Birth: 2023-02-18 00:16:05.996473718 -0600

@YYang Updating your instance to CryoSPARC v4.2 should resolve this issue. For information on v4.2 and the subsequent 230302 patch, please see the release notes.