Issues updating to cryoSPARC v2.12.2

closed

#1

After updating to V2.12.2, Local CTF Refinement seems to have disappeared from my Job Builder. Is this intentional? If not, any idea what might cause this?

The tutorial says it still should be available as a stand-alone job, although it implies running as part of homogeneous refinement is fast and simpler.

Regards,
-jh-

ps: FWIW this is stanalone on RHEL7 with CUDA 10.1.

> cryosparcm status
----------------------------------------------------------------------------
CryoSPARC System master node installed at
/home/cryosparc_user/V2.X/cryosparc2_master
Current cryoSPARC version: v2.12.2
----------------------------------------------------------------------------

cryosparcm process status:

app                              STOPPED   Not started
app_dev                          STOPPED   Not started
command_core                     FATAL     Exited too quickly (process log may have details)
command_proxy                    FATAL     Exited too quickly (process log may have details)
command_rtp                      STOPPED   Not started
command_vis                      RUNNING   pid 963, uptime 0:00:02
database                         FATAL     Exited too quickly (process log may have details)
watchdog_dev                     STOPPED   Not started
webapp                           RUNNING   pid 964, uptime 0:00:02
webapp_dev                       STOPPED   Not started

global config variables:

export CRYOSPARC_LICENSE_ID="xxxxxx"
export CRYOSPARC_MASTER_HOSTNAME="lomatia"
export CRYOSPARC_DB_PATH="/home/cryosparc_user/cryosparc_database"
export CRYOSPARC_BASE_PORT=39000
export CRYOSPARC_DEVELOP=false
export CRYOSPARC_INSECURE=false

#2

Hi @jmh,

Can you do cryosparcm restart, then cryosparcm cli "refresh_job_types()"


#5

Okay, I think I’ve fixed the problem. The issue seems to have been that things were not shut down cleanly at some point, so there was a /tmp/cryosparc-supervisor… file left sitting around even after stopping cryosparc, and attempts to communicate on this socket would fail. Stopping cryosparc, manually removing this file, rebooting the system, and then restarting cryosparc seems to have fixed things. One thing I notice which may have been preventing cryosparc from stopping / starting automatically during the update is that when I manually started cryosparc, an openSSH dialog now pops asking for cryosparc_users password. I’ve never seen this before, so it’s most likely a security feature introduced by a recent patch.


#6

Hello, I also encountered the same issue after updating. Can you please let me know how to fix this? Eager to run CTF refinement on cryosparc.
Thank you so much.
—Da


#7

Hi @dcui91,

To cleanly reinstall cryoSPARC, first:

  1. Ensure cryoSPARC is turned off:
    cryosparcm stop
  2. Then, ensure no zombie processes are still running. Kill the processes if they are.
    ps -ax | grep “supervisord” (kill only the process that is running from your cryosparc2 install)
    ps -ax | grep “cryosparc2_command” (kill all the matching processes related to your cryosparc2 
    instance)
    ps -ax | grep “mongod” (kill only the process running your cryosparc2 database)
    
    e.g. kill 82681
    
  3. Remove the socket file inside the /tmp folder
    /tmp/cryosparc-supervisor...XXX.sock
  4. Force reinstall cryoSPARC:
    https://cryosparc.com/docs/reference/install/#forced-update

#8

It worked. Thank you so much for your help.
—Da