Volume Tools Error: Cube volumes only

Dear All,

I am practicing the " Case Study: Yeast U4/U6.U5 tri-snRNP". Based on the tutorial I got the Mask for the head (head_mask.mrc) and the Mask for the part than the head.

With “Import 3D Volumes” I input the head_mask.mrc and got its imported.mask. Then I tried the “Volume Tools” to try to dilate the imported-mask based on the tutorial.

I do not know whether I understand the tutorial correctly. For this “Volume Tools” step, for “volume” I input the refined volume from previous homogeneous refinement based on which I got the head.mrc and the corresponding imported-mask. For “mask” I input the “imported-mask” just got from head.mrc.

Unlike the tutorial, there was no “Type of volume being changed” in this recent version of cryosparc “Volume Tools”. For “Type of input volume” of “Volume Tools” I input “mask”. For “Type of output volume” of “Volume Tools” I input “mask”. I input threshold as 0.05 (I am not sure how much to input for this parameter, and please give an explanation on it, and I have also tried to input other values for this parameter, it gave the same error message as following) and “Dilation radius” as 5 based on the tutorial, and then I run this “Volume Tools”, it gave the following error:

Traceback (most recent call last):
File “cryosparc_worker/cryosparc_compute/run.py”, line 84, in cryosparc_compute.run.main
File “/home/userABC/mycryosparcv3/cryosparc_worker/cryosparc_compute/jobs/utilities/run_volume_tools.py”, line 50, in run
assert n.all(n.array(input_shape)==N_input), “Cube volumes only”
AssertionError: Cube volumes only

For “Type of input volume” of “Volume Tools” I also have input as “map”, and the “Volume Tools” gave the same error message as above.

I am looking forward to getting your reply on all issues related to this import volume error.

Best wishes,


I see nobody replied, maybe because there’s already a post: Errors in using an imported volume

This post did not help me:

  • I do not have a structure, so can’t use ‘molmap’.
  • I tried resampling in ChimeraX, and still the Volume tools returns Error: Cube volumes only
  • imported the binarized+resampled map as a map instead of a mask, still got the error
  • imported the non-binarized map as a mask and a volume, still got the error
  • tried at least 10 different parameter values and various settings, still no luck :frowning:
  • I always check that the map looks good in ChimeraX and the map looks fine on import

I have had more luck with a map exported from cryoSPARC. Any map imported from ChimeraX just fails with the Cube volumes only error.

I am stuck and frustrated.

Hi Flemming, are you sure the mask is a cube? I am not familiar with the tutorial files, but I would check this first. In chimera, the Volume Viewer window will show the map/mask dimensions in voxels to the right of the volume name. You could also check the graphic in the “import volume” job you ran in cryosparc, which indicates volume dimensions.

I am not familiar with ChimeraX, but in chimera I would run “vop resample #vol1 ongrid #vol2” where vol2 is the reference. Then save the new volume and ensure its dimensions are a cube with one of the two methods above. You could molmap a PDB to generate vol1 which is a subset region of vol2, or you could use the segmentation tool in chimera or the volume eraser to slice up the original map since you don’t have a PDB. The segmentation tool will shrink the volume such that you must resample ongrid to the reference (starting map).

Regarding your question about the threshold, this is a map contour level you must choose which essentially sets the size of the mask. Open the original map alongside the map you are using as the starting point for your mask. Adjust the threshold of this map to engulf the region of the reference you are interested in. Then set a dilation radius, which adds more volume beyond the threshold level.

Thank you user123 for your help! I had 2 issues with my mask: it was not exactly a cube, and I discovered that the side of the cube had to be an even number or else the Volume tool would throw an error.

1 Like

Hi everyone!

Maybe this old discussion can help you with this problem:

Some of the solutions they proposed are:
Resampling on the grid of the original map - e.g. vop resample #map1 ongrid #map2
or by Using molmap with the ongrid option - e.g. molmap sel 20 ongrid #mymap

Good luck!