Update problem Worker version

Hi I just update from v2.5 to v3.0 but somehow the worker version fail to update. How can I fix this problem?

Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/run.py”, line 46, in cryosparc2_compute.run.main
AssertionError: Version mismatch! Worker version (v2.15.0) and Master version (v3.0.0) are not the same. Please updat


I have a similar problem. The update process fired a lot of warning signals but the master installation was updated and seems to work fine. However, when I try to run jobs I get the same error. When I look in cryosparc_worker folder I see that the .tar.gz file is from May 2020. When I try to update using bin/cryosparcw it tells me

Current version v2.15.0 - New version v2.15.0
Already up to date

I can send the full installation log if necessary but it is long. The worker installation does seem to have downloaded correctly though:

Downloading worker update...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 2903M  100 2903M    0     0  14.1M      0  0:03:25  0:03:25 --:--:-- 27.2M÷



Hi all, this indicates that that master updated but the worker did not, here’s how to fix it:

  1. Navigate to the cryosparc2_master folder
  2. Look for the file called cryosparc2_worker.tar.gz or cryosparc_worker.tar.gz. Copy this file into the cryosparc2_worker directory
    • Important: If you’re upgrading from v2 to v3, rename the this file to cryosparc2_worker.tar.gz
  3. Navigate to the cryosparc2_worker directory
  4. Run this command:
    bin/cryosparcw update --override

Thanks! I did what you suggested and it worked right away! Now our patch motion correction job on 13 000 K3 images is running!

1 Like

Hi @nfrasser, in my case the file in the master directory is named cryosparc_worker.tar.gz, not cryosparc2_worker.tar.gz.

Copying this to the worker directory doesn’t solve the issue, as the update is looking for the latter - you need to rename it to cryosparc2_worker.tar.gz as well, then it works

Yes, thanks for point this out @olibclarke . The initial update run should download cryosparc2_worker.tar.gz but if you attempt to fix an incomplete update it’ll end up as cryosparc_worker.tar.gz. Edited my answer in note this.