Trouble importing jobs to cryosparc 3.2


I started a project in cryosparc 3.1 instance. There was unexpected problem with its database. So I started a new instance in crysparc 3.2. I imported the projects. The project and workspace are imported but none of the job is getting imported. I tried to import a job individually and it is not working.

While importing I received audit erro and I followed up the instructions in Project import error in 3.2 name 'audit' is not defined
I did patch update and tried, it did not work.
I checked the workspace.json file and it is not empty.
I could not find a solution. Can you please help?

Hi @iswaryapj,

Is it possible if you can provide more information about the error you’re seeing?
You should be able to find a traceback in the command_core logs (cryosparcm log command_core, press CTRL+C to exit from trailing mode and enable scrolling up).

I had the same problem when I just tried importing an old job into Cryosparc 3.2. I applied the patch and also saw a lack of workspaces, but then tried to make a new workspace in the project and it loaded all of my jobs into it. I can make and run new jobs using files from the old jobs. So, it’s fixed? I only had one workspace in the project. Not sure if it’d work if you had more than one workspace, but maybe you could keep adding new workspaces until you had the same number as your original project?

Hi Stephan,
Thanks for trying to help me.
Another job is in progress now, so I could not do this now.
I could find the following error message from the notification manager, which I got while importing project as well as importing a job.
I wish to emphasize that while importing the project, the project and workspace are imported, but none of the jobs.

Error message
Unable to import project from /path/To/old/project/directory/P2: name ‘audit’ is not defined

Now, I created a new workspace inside the imported project and tried to import a job into it. I got the following error message.
Import Job Error in P1: Job is not located inside project directory. Please move the job folder into /old/project/directory/P2/imports

Are these info good enough to help me?

Hi HCall,
Do the poject name has to be the same as the orginal. If it was P2, do it strictly have to be P2 to import it? Given that I ave made the mistake of importing old_P2 to new_P1, what should I do to solve the issue.


I gave mine a completely new name. Seemed to work fine.

Hi HCAll and Stephan,

The problem is solved. There was error in patch installation. Once it was done correctly, the import job was smooth :slight_smile:


1 Like