Project import error in 3.2 name 'audit' is not defined

Dear all,

I tried to import a project in cryoSPARC 3.2 but got this error:
‘Unable to import project from /x/x/x: name ‘audit’ is not defined’
I would appreciate any help!

Best regards,
Gabor

Hi @gabor,

Thank you for reporting. This is a bug- I’ll keep you updated on when a fix will be released (hopefully soon).

Hi @gabor,

We’ve fixed this bug in Patch 210401 (for v3.2.0).

To apply this patch, please follow the instructions available here: Apply Patches

3 Likes

Hi Stephan,

Thank you for the patch, it works now.

Best wishes,
Gabor

Hi @stephan

Just to add to this, I followed the above for patching and could now import the project but my workspaces are empty. I followed this.

I can see thumbnails from the Projects window but when I open the workspace window there is nothing there. The details for my project show its size of 1.7 TB and all the data seems fine but I just can’t access it.

Any help would be greatly appreciated?

Best
Mike


Hi,

I had the same before. In fact when you first tried to import your project without success, the workspaces.json (in your project directory) is emptied. Luckily I had a backup and I could restore it from there.

Best,
Gabor

hi @gabor

that worked wonderfully thank you.

@stephan, would it be possible to have a constant workspaces.json.bak or something similar for these cases?

Best
Mike

Hi @mplockhartuom, @gabor,

Sorry for the inconvenience. This looks like some sort of bug- can you explain in detail what you did? Do you also think you can provide any logs from the failed import (by running cryosparcm log command_core, pressing ctrl+c then scrolling up to any error so you can copy+paste it here)?

Dear @stephan,

I don’t have error in the log, it maybe cleared after the patch install.
What I did was the following:

  1. tried to import a project (P2) to the new cryoSPARC instance - failed with ‘audit’ is not defined
  2. installed the patch
  3. tried again to import P2, but I couldn’t access the workspaces like @mplockhartuom .
  4. I copied from a backup the workspaces.json to P2/ replacing the empty file in the directory.
  5. I re-imported the P2 project and it was successful.

Best,
Gabor