Problem updating to 2.15

Hi … I have a weird problem. I tried updating to version 2.15, so I did the suggested cryosparcm update, and apparently everything installed fine with the master, but then it gets to the point of doing “starting cryosparc” to install the worker node, and dies… it just hangs there. Then it seems that cryosparcm becomes into a vegetative state, since doing cryosparcm restart does nothing… just hangs… cryosparcm help works fine; cryosparcm status hangs and cryosparcm env works fine too. Then I decided to do a fresh install, deleting the cryosparc2_master and cryosparc2_worker directories, and reinstalling everything, but to no avail, as the result is exactly the same. The command that I am using to install is as follows:

./ --standalone --license $LICENSE_ID --worker_path /home/rdiaz/cryosparc/cryosparc2_worker/ --cudapath /usr/local/cuda --ssdpath /ssd1 --initial_email --initial_password ******** --initial_name rdiaz

Any help will be greatly appreciated.


HI Ruben,
same issue here. looks like Oliver had the same issue, see here for work around


Hi… I tried the workaround, but I guess it does not apply to me, as I do not have the live version… I tried removing the “live” part and nothing, but still, it seems to be a different issue, since both in the master folder and in the worker, the version file says v2.15.0, so it does not seem to be a version mismatch. Is there a way to revert to the 2.14 version? That one seemed to work fine, but I would need to re-download it. Thanks!!

Hi @Ruben1, before you revert to 2.14 can you private-message me with all the .log files from the cryosparc2_master/run directory? This would really help me troubleshoot the issue.

You can find instructions for how to revert to a previous cryoSPARC version here:

For example:

cryosparcm update --version=v2.14.2

Hi… i looked for the log files that you requested, but there are none… there is no cryosparc_master/run directory at all.

Hi @Ruben1, that should be alright, did the update back to v2.14 work?

Hi… yes, the installation back of 2.14 went without a problem. I am quite puzzled by it, since i honestly did not do anything differently, but am glad that it works. Thank you!!