Local motion failing with error


Local motion correction (both versions) is failing with an error, and I can’t figure out why. Any ideas from inputs and errors below greatly appreciated!


Do you usually use *.frames.tif ?
I remember to had problems with file name interpretations of preliminary “.” in the past.

yes I do… hadn’t realized that was an issue!

@olibclarke Were you able to avoid the error given @tarek 's suggestion?

Hi @wtempel - I’m not sure exactly how to implement a fix? Do I need to rename all my movies, re-import, then redo motion correction? That would be a bit much just for a test…

@olibclarke I was just checking in case you could already confirm this to be the cause of the problem.
What command did you run to get the terminal output (screenshot with the black background)?
The output of
cryosparcm log command_core > path-to-core.out
may provide additional clues.

Hi @wtempel this log was from cryosparcm joblog - I will rerun it when the GPU is free with the command core log running and send you the output!


Dear all, I am also facing an issue with local motion failing:

My filenames do not have *.frames.tif (screenshot attached)


all is default except boxsize 416 and gpu x 2 in use.

An output of particles is still generated but I am not sure if these particles are any better.

@chew0357 Do any of the scenarios discussed in this topic apply in your case?

Thanks @wtempel for linking me to the other thread, likewise to AndreGraca I leave Only process this many movies parameter blank.

In addition, the failed local motion has blocked all other gpu jobs from occuring but left the gpus idle. I am running on CUDA version 11.6, cryosparc version: v3.3.1+220215.

I will test the following solution:
“An alternative cause for the error could be the input of movies without any associated particles. You may test for (and correct) this condition by connecting particles (in addition to rigid/patch-corrected micrographs) to a Manually Curate Exposures job that precedes Local Motion Correction

get back to you again later

Hi @wtempel, there do not appear to be any relevant entries in the command_core log.

I can run local motion fine on EMPIAR data (I tried with EMPIAR-10500), and it works and results in improved resolution, so I would like to try it on my data.

When I run with the non-multi version of local motion, I get the attached error. The inputs are a particles blob from non uniform refinement, and a micrographs blob from the preceding extract from Micrographs job - is this okay? The micrographs blob seems to have all the required slots connected.

I do notice that the “run_local.py” file referenced in the error does not seem to exist at the specified path - in that subfolder I can only see a motioncor2 script, nothing regarding local motion.


Release 3.3.2 includes a fix for the error reported in Local motion failing with error - #11 by olibclarke.

1 Like

Can confirm, just tested this and it works now for the dataset on which it was failing previously, thanks!

1 Like