Local motion correction with EER file not working (resolved with patch)

Hi all,

I’m processing an EER data set, and I had no problem until I tried to run a local motion correction on my refined model. So what I mean is that I could run the usual pre-processing, picking, 2D, ab-initio and several 3D refinements (new and legacy), but cryosparc fails to run a local motion correction.
The error is the following:

[CPU: 896.1 MB] --------------------------------------------------------------
*[CPU: 896.1 MB] Processed 0 of 3733 movies in 0.01s *
[CPU: 896.2 MB] (0 of 3733) Processing J1/imported/FoilHole_16051285_Data_16047961_16047963_20210616_194420_EER.eer
Motion correcting and extracting 486 particles (0 rejected near edges)

[CPU: 896.2 MB] Loading raw movie data from J1/imported/FoilHole_16051285_Data_16047961_16047963_20210616_194420_EER.eer …

[CPU: 502.2 MB] Traceback (most recent call last):

  • File “cryosparc_worker/cryosparc_compute/run.py”, line 84, in cryosparc_compute.run.main*
  • File “cryosparc_worker/cryosparc_compute/jobs/motioncorrection/run_local.py”, line 446, in cryosparc_compute.jobs.motioncorrection.run_local.run_local_motion_correction*
    AssertionError: Cant read extension .eer

As an input I used the particles from a NU refinement job, and the micrographfs from the original Ctf (after motion correction). I tried also from the micrographfs from the extraction, with the same result.

Any tips?

1 Like

Just to add that trying “(Local motion correction (multi))” gives me a similar, but different, error:

[CPU: 70.5 MB] Importing job module for job type local_motion_correction_multi…

[CPU: 192.1 MB] Job ready to run

[CPU: 192.1 MB] ***************************************************************

[CPU: 206.2 MB] Particles already have CTF estimates: these will not be modified.

[CPU: 728.8 MB] num_movies 3733

[CPU: 728.8 MB] parent process is 109657

[CPU: 743.4 MB] Calling CUDA init from 114362

[CPU: 844.4 MB] – 0.0: processing J1/imported/FoilHole_16051285_Data_16047961_16047963_20210616_194420_EER.eer
Loading raw movie data from J1/imported/FoilHole_16051285_Data_16047961_16047963_20210616_194420_EER.eer …
Loading gain data from J1/imported/FoilHole_16051285_Data_16047961_16047963_20210616_194420_EER.eer …

[CPU: 1.48 GB] Traceback (most recent call last):
File “/cephfs/vicente/cryosparc/cryosparc_worker/cryosparc_compute/jobs/runcommon.py”, line 1790, in run_with_except_hook
run_old(*args, **kw)
File “/cephfs/vicente/cryosparc/cryosparc_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/threading.py”, line 870, in run
self._target(*self._args, **self._kwargs)
File “/cephfs/vicente/cryosparc/cryosparc_worker/cryosparc_compute/jobs/pipeline.py”, line 86, in stage_target
work = processor.exec(item)
File “/cephfs/vicente/cryosparc/cryosparc_worker/cryosparc_compute/jobs/pipeline.py”, line 43, in exec
return self.process(item)
File “cryosparc_worker/cryosparc_compute/jobs/motioncorrection/run_local.py”, line 133, in cryosparc_compute.jobs.motioncorrection.run_local.run_local_motion_correction_multi.motionworker.process
File “cryosparc_worker/cryosparc_compute/jobs/motioncorrection/run_local.py”, line 173, in cryosparc_compute.jobs.motioncorrection.run_local.run_local_motion_correction_multi.motionworker.process
File “/cephfs/vicente/cryosparc/cryosparc_worker/cryosparc_compute/blobio/mrc.py”, line 139, in read_mrc
data = read_mrc_data(file_obj, header, start_page, end_page, out)
File “/cephfs/vicente/cryosparc/cryosparc_worker/cryosparc_compute/blobio/mrc.py”, line 89, in read_mrc_data
dtype = mrc_datatype_to_dtype(datatype)
File “/cephfs/vicente/cryosparc/cryosparc_worker/cryosparc_compute/blobio/mrc.py”, line 68, in mrc_datatype_to_dtype
assert False,‘Unsupported MRC datatype: {0}’.format(datatype)
AssertionError: Unsupported MRC datatype: 1820068802

Never mind, I found that I was missing a patch…