Gain reference from falcon4 camera


I tried to do motion correction with .eer file collected from falcon 4 camera, and I received this error:

  Loading gain data from J7/imported/000263580115278685410_FoilHole_17683150_Data_17681946_17681948_20220118_195424_EER.eer ...

[CPU: 201.1 MB] Error occurred while processing J7/imported/000263580115278685410_FoilHole_17683150_Data_17681946_17681948_20220118_195424_EER.eer
Traceback (most recent call last):
File “/work/FAC/FBM/DMF/sgruber1/cryoem_gruber/cryosparc/cryosparc_worker/cryosparc_compute/jobs/”, line 53, in exec
return self.process(item)
File “cryosparc_master/cryosparc_compute/jobs/motioncorrection/”, line 109, in
File “cryosparc_master/cryosparc_compute/jobs/motioncorrection/”, line 145, in
File “/work/FAC/FBM/DMF/sgruber1/cryoem_gruber/cryosparc/cryosparc_worker/cryosparc_compute/blobio/”, line 140, in read_mrc
data = read_mrc_data(file_obj, header, start_page, end_page, out)
File “/work/FAC/FBM/DMF/sgruber1/cryoem_gruber/cryosparc/cryosparc_worker/cryosparc_compute/blobio/”, line 88, in read_mrc_data
dtype = mrc_datatype_to_dtype(datatype)
File “/work/FAC/FBM/DMF/sgruber1/cryoem_gruber/cryosparc/cryosparc_worker/cryosparc_compute/blobio/”, line 65, in mrc_datatype_to_dtype
assert False,‘Unsupported MRC datatype: {0}’.format(datatype)
AssertionError: Unsupported MRC datatype: 1243414722

Marking J7/imported/000263580115278685410_FoilHole_17683150_Data_17681946_17681948_20220118_195424_EER.eer as incomplete and continuing…

i have a gain file that has .gain format, and i am using cluster with Slurm schedular, the version i have is v3.3.1+220315

Hi @yli18 , maybe you need to update your cryosparc up to the latest patch so that it can support eer files properly… Local motion correction with EER file not working (resolved with patch) - #2 by sente

Can you confirm that FoilHole_17683150_Data_17681946_17681948_20220118_195424_EER.eer is indeed the intended gain reference file? I would not have expected an EER file to provide the gain data.
Something might have gone wrong during the preceding eer file import (Job J7?). What was specified for

  • Movies data path
  • Gain reference path

You can find the information under the Inputs and Parameter tab of the import job (J7).


Seeing a related issue with the following error in patch motion.

Error occurred while processing J298/imported/014569539110538124320_FoilHole_13005754_Data_12924297_12924299_20220613_194521_EER.eer
Traceback (most recent call last):
File “/home/cryosparc_user/V3.X/cryosparc_worker/cryosparc_compute/jobs/”, line 60, in exec
return self.process(item)
File “cryosparc_master/cryosparc_compute/jobs/motioncorrection/”, line 118, in
File “cryosparc_master/cryosparc_compute/jobs/motioncorrection/”, line 139, in
KeyError: ‘gain_ref_blob/path’

May we have a look at the job.json files of this failed job and of job J298?

emailed files to

The json file for the upstream import job, which you emailed us, specifies a Gain reference path that may not be in MRC format. I wonder if this caused a problem during import, which in turn may have lead to the KeyError.
If the gain reference is indeed not already in MRC format, you may want to retry the upstream import and this motion correction job after converting the gain reference to MRC format. Your microscope facility may be able to help with the conversion.

Tried that using both tif2mrc and newstack. Still have the same error.

Any update on this issue? I have used multiple file conversion and still achieve the same error

This appears to be related to the update. All works fine in v3.3.1. This error only occurs in v3.3.2+220518

To help us identify the cause, please clone a job that succeeded on v3.3.1 (“old job” ) and execute that job on v3.3.2+220518 (“new job”). After confirming that the clone fails, please collect for this pair of jobs:

  • job.json
  • job.log

In addition:

  • job.json from the (common) upstream import job
  • one raw movie file that’s cited in the error message of the “new” motion correction job
  • the error message from the “new” job’s Overview tab
  • the gain reference and defect file (if used during import)

I will send you direct message regarding data transfer arrangements.

Hello, I am also having this issue. I am using version 3.3.2. The import movies seems to work okay, but when looking at the imported eer files, they only come out to 139 bytes.

I guess the 139 bytes is not a huge deal. I went back and looked at other import jobs and this is on about the same level as previous.

Because several issues have been discussed under this topic, please post

  • the error message you observed
  • the patch level of you CryoSPARC instance, if any
  • a screen shot of the failed jobs Inputs and Parameters tab

I was running v3.3.2 (no patch) for these errors.
Here is my error message for one of the eers, but this occurred again and again for most of the movies:

[CPU: 228.9 MB] Error occurred while processing J1/imported/004745586021228548817_FoilHole_9006262_Data_8993834_8993836_20220909_010506_EER.eer
Traceback (most recent call last):
File “/home/renee.arias/cryosparc/cryosparc_worker/cryosparc_compute/jobs/”, line 60, in exec
return self.process(item)
File “cryosparc_worker/cryosparc_compute/jobs/motioncorrection/”, line 117, in
File “cryosparc_worker/cryosparc_compute/jobs/motioncorrection/”, line 139, in
File “/home/renee.arias/cryosparc/cryosparc_worker/cryosparc_compute/blobio/”, line 86, in read_eer
eer = open_eer(fname)
File “/home/renee.arias/cryosparc/cryosparc_worker/cryosparc_compute/blobio/”, line 15, in open_eer
return eerdecompressor.ElectronCountedFramesDecompressor(str(fname))
RuntimeError: unable to open tiff file

Marking J1/imported/004745586021228548817_FoilHole_9006262_Data_8993834_8993836_20220909_010506_EER.eer as incomplete and continuing…

And here is the Inputs and Parameters screenshot:

I just implemented the latest patch (I think it is 220824) and am currently importing the images again. Perhaps that will be the fix.

After implementation of the patch, I got a new error:

Error occurred while processing J2/imported/015153351232888067961_FoilHole_9006286_Data_8993834_8993836_20220909_010807_EER.eer
Traceback (most recent call last):
File “/home/renee.arias/cryosparc/cryosparc_worker/cryosparc_compute/jobs/”, line 60, in exec
return self.process(item)
File “cryosparc_master/cryosparc_compute/jobs/motioncorrection/”, line 118, in
File “cryosparc_master/cryosparc_compute/jobs/motioncorrection/”, line 133, in
File “cryosparc_master/cryosparc_compute/blobio/”, line 71, in cryosparc_compute.blobio.prefetch.synchronous_native_read
RuntimeError: Error ocurred (Input/output error) at line 903 in open
Could not open file. Make sure the path exists.

IO request details:filename: /home/renee.arias/data/em/220908_beta_gal_glacios/proc/P9/J2/imported/015153351232888067961_FoilHole_9006286_Data_8993834_8993836_20220909_010807_EER.eer
filetype: 2
header_only: 0
idx_start: 0
idx_limit: -1
eer_upsampfactor: 2
eer_numfractions: 35
num_threads: 6
buffer: (nil)
nx, ny, nz: 0 0 0
dtype: 0
total_time: -1.000000

Marking J2/imported/015153351232888067961_FoilHole_9006286_Data_8993834_8993836_20220909_010807_EER.eer as incomplete and continuing…

I did verify that the path is correct and exists.

Inside the directory that you specified as Movies data path, please can you run the command
stat FoilHole_9006286_Data_8993834_8993836_20220909_010807_EER.eer and post the command’s output here?

Here it is (I replaced my colleague’s name with the generic

File: 'FoilHole_9006286_Data_8993834_8993836_20220909_010807_EER.eer'
  Size: 901309466       Blocks: 1760993    IO Block: 131072 regular file
Device: 27h/39d Inode: 1935        Links: 1
Access: (0777/-rwxrwxrwx)  Uid: ( 1001/   Gid: ( 1001/
Access: 2022-09-12 14:41:12.906309647 -0700
Modify: 2022-09-09 01:07:55.818618200 -0700
Change: 2022-09-12 14:41:12.915309677 -0700
 Birth: -

Were any of the eer files successfully imported?