Library ( error after 2.12 update

Has anyone else encountered the following and found a solution?

After updating to 2.12 on CentOS 7 and compiling against CUDA 8 everything works fine but I realise I should have compiled against a newer CUDA version to use CtfRefine etc. So I recompile against CUDA 10.0 by doing a fresh installation. However, now when I start CryoSPARC ($ cryosparcm start) after the ‘command_core: started’ is reported the following error prints on repeat until I exit.

curl: error while loading shared libraries: cannot open shared object file: No such file or directory

Any thoughts or solutions? Is this a new dependency? I’ve googled and stack exchanged a bit but not found the obvious solution other than tomorrow to do a fresh install of the system openssl.

Thanks so much for your help!

Hi @kylelmorris,

I haven’t encountered this specific error message, but I just wanted to see if you knew about the cryosparcm newcuda function. You can specify the path to a CUDA toolkit and the bash script will recompile pycuda (the only dependency that requires compilation during install time) against it. This way, you don’t have to do a whole reinstall every time.

Hi @stephan, thanks for the tip, that’s a good one and I’ll use in the future! I see the cryosparcm commands are documented here in management and monitoring but it would be really helpful if when executing cryosparcm without inputs or with -h the available commands were reported to the terminal to quickly spot options like this one.

Regarding this error, I found a solution of sorts, at least in my local environment. When installing CryoSPARC I was dropping into a TTY (Ctrl-Alt-F2) to avoid any environment issues upsetting CryoSPARC. This has worked in the past and avoided system anaconda problems (see: Can't start after update to 2.8). For the version 2.12.0, using this method results in the above reported error when starting cryosparm in a terminal. When I installed 2.12.0 in a standard interactive terminal the install proceeds and then cryosparcm starts normally.