Install on CentOS 6: webapp EXITED

Hi, everyone
I have tried to install the cryoSPARC on a Ubuntu desktop and it works fine, but when I want to install it on a CentOS server the webpage can’t be loaded. I tried to turn off the SELinux but still can’t open the web page. The cryosparc status command gives me the information: webapp Exited
Can anyone give me some help? Thanks very much!

Have you tried opening a port? CentOS comes with most ports closed by default.
Try this:

$ sudo firewall-cmd --zone=public --add-port=38000/tcp --permanent
$ sudo firewall-cmd --reload

$ sudo iptables -I INPUT -p tcp -m tcp --dport 38000 -j ACCEPT
$ sudo service iptables save

How to open a port RHEL/CentOS


Thanks Mike for answering.
Huanyu can you also look at the output in cryosparc/run/meteor.stdout to see if there was an error message?


If you are running CentOS 6, installation go accordingly, cryosparc start works properly and the webapp does not work the problem most likely will be the GLIBCXX library. This can be confirmed by checking cryosparc/run/meteor.stdout.

If that is the problem, the solution is can be found here, Outdate CentOS6 GLIBCXX

I had that problem and that is how I fixed it.

Hi, I got the same problem. The meteor.stdout writes:

throw new assert.AssertionError({
AssertionError: “undefined” === “function”
at wrapPathFunction (/home/xiaorun/Software/SPARC/cryosparc-webapp/bundle/programs/server/mini-files.js:77:10)
at Object. (/home/xiaorun/Software/SPARC/cryosparc-webapp/bundle/programs/server/mini-files.js:108:24)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/home/xiaorun/Software/SPARC/cryosparc-webapp/bundle/programs/server/boot.js:9:13)
at Module._compile (module.js:456:26)

I’ve got no idea what’s going wrong.

Thanks for your guys’ help!


I think you may be having a different error (since there’s no mention of GLIBCXX in your error log).
Can you do the following, as the user that installed cryosparc:

eval $(cryosparc env)
which node
(this should be /home/xiaorun/Software/SPARC/nodejs/bin/node)
node --version
(this should be v4.6.2)

Apparently the error you are getting happens when your node version is wrong (but node is installed by our installer as a cryosparc dependency, so the only way you might have the wrong version is if you already had node installed on the system)

Hi Ali,

You are right. Node (v0.10.48) was installed earlier on the system. So what can I do now? Install a local node of v4.6.2?


During installation there should have been a part that indicated that a previous node installation was available and asked if you want to install a local (to cryosparc) copy anyway. The easiest thing is probably just to remove the current installation and install again, but at that stage tell the installer to install node again locally anyway. Presumably you haven’t run any jobs so you don’t have to worry about any data loss from just deleting your SPARC folder.

I managed to install it successfully in the end. Thank you all!