Webapp started but page will not launch


Upon installing cryosparc, the web app will not load in my browser. Nothing loads when I navigate to localhost:39000.
See the following outputs:

[jacque@XX cryosparc2_worker]$ cryosparcm status

CryoSPARC System master node installed at
Current cryoSPARC version: v2.9.0

cryosparcm process status:

command_core RUNNING pid 25623, uptime 0:19:24
command_proxy RUNNING pid 25835, uptime 0:19:20
command_vis RUNNING pid 25723, uptime 0:19:22
database RUNNING pid 25465, uptime 0:19:26
watchdog_dev STOPPED Not started
webapp RUNNING pid 25910, uptime 0:19:19
webapp_dev STOPPED Not started

global config variables:

export CRYOSPARC_DB_PATH="/home/jacque/cryosparc/cryosparc2_database"

[jacque@wudang-new cryosparc2_worker]$ cryosparcm log webapp
cryoSPARC v2
Ready to serve GridFS
cryoSPARC v2
Ready to serve GridFS
cryoSPARC v2
Ready to serve GridFS
cryoSPARC v2
Ready to serve GridFS
cryoSPARC v2
Ready to serve GridFS
cryoSPARC v2
Ready to serve GridFS
cryoSPARC v2
Ready to serve GridFS

Any help launching is much appreciated. Thanks!!

Hi @JacqueFaylo,

What OS are you using?

I am using CentOS 7.

Hi @JacqueFaylo,

1 Like

Thanks, but I tried opening the port (39000) - I still have the same problem
I have GLIBCXX up to 3.4.19

Anything else I should check or try?

Hi @JacqueFaylo,

Can you open ports 39000-39005? CryoSPARC uses 5 ports for the webapp, the database, the main API, the visualization API, and the proxy API.

1 Like

OK, I opened all 5.

Has not worked yet

Can you try restarting? cryosparcm restart
Are you trying to access the webapp from the same machine? If you’re accessing it from another machine, can you make sure port forwarding is set up properly? You can check here for a small tutorial:

Please also check out previous posts in this discussion forum.

Thanks, but I am trying to access the webapp locally and not a remote host. I tried cryosparm restart many many times.
I deleted and reinstalled and I thought that I had it figured out but now I have connection error. It is the same “Assertion Error” as the last line of the following post:
V2 installation error - " RequestsDependencyWarning: urllib3 (1.23) or chardet (3.0.4) doesn't match a supported version!"

If anyone knows how the above got solved, I would appreciate!
(Assertion error is the following):
{u’message’: u’OtherError: XX:39001: [Errno 111] Connection refused’, u’code’: 500, u’data’: None, u’name’: u’OtherError’}


I had this error appear, and one of the things to check is that all your dependencies are properly installed, and that cryosparc is actually looking at the right directories. Are you using conda? Also restarting your terminal session and killing all jobs related to CS (ps -ax | grep “supervisord”) plus removing residual files (rm /unix:///tmp/cryosparc-supervisor-************.sock) might help you (before installing again or starting cryosparcm). Good luck!

Thank you!!!
You’re right, I had a big dependency problem. I also kept re-installing too many times. I thought that if you delete the cryosparc folder and delete the export path from your ~/.bashrc, then it would be fine, but it turns out that each installation was still in memory. Once the residual jobs and files were killed and removed, and I had the right dependencies, I was able to install and launch!

1 Like