Importing job module for job type new_local_refine Failed in Local Refinement of v3.1.0

Hi All,

I got the following error when I started Local Refinement (New! BETA). Any suggestion? Thanks.

License is valid.
Launching job on lane default target …
Running job on master node hostname
[CPU: 81.2 MB] Project P15 Job J59 Started
[CPU: 81.2 MB] Master running v3.1.0, worker running v3.1.0
[CPU: 81.8 MB] Running on lane default
[CPU: 81.8 MB] Resources allocated:
[CPU: 81.8 MB] Worker:
[CPU: 81.8 MB] CPU : [0, 1, 2, 3]
[CPU: 81.8 MB] GPU : [0]
[CPU: 81.8 MB] RAM : [0, 1, 2]
[CPU: 81.8 MB] SSD : False
[CPU: 81.8 MB] --------------------------------------------------------------
[CPU: 81.8 MB] Importing job module for job type new_local_refine…
[CPU: 81.8 MB] Traceback (most recent call last):
File “cryosparc_worker/cryosparc_compute/”, line 71, in
File “/home/groups/kornberg/donghuac/cryosparc/cryosparc2_worker/cryosparc_compute/jobs/”, line 356, in get_run_function
modname = job_types_modules[str(job_type)][‘run_module’]
KeyError: ‘new_local_refine’

Hi @donghuachen, can you run the following commands, then try again?
cryosparcm restart
cryosparcm cli "refresh_job_types()"

I tried both commands and the job still failed with the same error.

@donghuachen Can you please try the steps outlined here?

Edit: And please also try running a new Local refinement job (rather than cloning or clearing the old one)


Followed your suggestions and now it is working.

  1. Navigate to cryosparc2_worker, run the command: bash ./bin/cryosparcw update --override
  2. start a new local refinement job

Thanks so much!