ID error: Another cryoSPARC instance is running with the same license ID

All the jobs I want to run are suddenly giving me this error:
Token is invalid. Another cryoSPARC instance is running with the same license ID.

I have checked that the ID I use is correct.
I am the only user with that ID, I’ve been successfully running jobs in the last few days, and haven’t changed anything since the last job that ran correctly.

Do you have any suggestions why this has come up? Any idea how I can correct for this?

Thanks

Hi @Anais, I am going to message you directly.

Hello @spunjani ,

I have been experiencing the same problem when trying to run a job.

Could you please advise me on this?

Thanks

I am having a similar problem running my first job. I have checked my license and it is correct. No other users on my machine. I am running a master computer with two workers

Hi @scott, any chance you used the same license ID for multiple installs?

Dear @spunjani, we have been having something similar. Occasionally, cryosparc complains that the token ID is invalid, and that another cryosparc instance is running with the same licence ID. If we stop and start cryosparc again with cryosparcm, cryosparc runs for awhile, until it throws up the same error message again. Cryosparc is installed and runs on a single workstation, to which people log onto. Can you please advise on to fix this?

@Luca, You will need a unique license ID for each cryoSPARC installation, otherwise you will receive the ‘Token is Invalid’ message.

You can obtain additional license IDs at cryosparc.com/download. Once obtained, you can update the license ID of an existing installation as follows: Stop cryoSPARC (cryosparcm stop), edit the config.sh file to replace the CRYOSPARC_LICENSE_ID, and then start cryoSPARC again (cryosparcm start).

@spunjani we ran just now on the same issue. I am not sure where it came from. What we have just done is the following, we have an instance on our Krios microscope on a workstation and we have a general cluster instance. Both have seperate licences. We just transferred Data from the one instance to the other. Could this be the cause? What could we do. We dont have dual installations with the same key.

Best,

David

@david.haselbach Can you please paste the text of the error message(s) you are receiving? Thanks!

Token is invalid. Another Cryosparc instance is running with the same licence ID.

As suggested, we restarted and worked for a while again but it came back but was again fixed by restart.

Same problem appeared to me now as well: unique installation on one single workstation with only one single cryoSPARC user.

@AndreGraca If the problem persists, would you be able to restart your instance:
cryosparcm restart
(running jobs would likely be disrupted)
and check if the problem goes away?

Hey team, I think I’m having the same issue here: I get

Queued
Token is invalid. Another cryoSPARC instance is running with the same license ID.

message after I clone & run the job I ran before. Before that, I was getting:

Error connecting to cryoSPARC license server. Checking local license file. The read operation timed outLocal license file is expired. Please re-establish your connection to the license servers.

and I did cryosparcm restart, which helped me to run a single job (!) which is now successfully running, but I’m weirdly unable to run multiple jobs on my instance now, which was possible before.

Obviously, this is the only one instance that I’m running.

1 Like

Same here. This occured after updating my cuda installation. I can it to run a single job but not multiple.

@marinegor @stavros
Please can you describe your observations when a second cryoSPARC job fails to run. What are the error messages, where and when are they displayed?
Are there any indications of “zombie” cryoSPARC-related processes leftover from a previous run of
cryosparcm start?
ps -ef | grep cryosparc_

2 Likes

Yes that was the issue, there was a lingering “zombie” process in the background. Once that cleared, everything is running normally. Thanks @wtempel !

2 Likes

I’m not sure now, since I couldn’t reproduce the bug – I restarted the crysparc twice after that, and one of the restarts helped.

Although, after the first one (when nothing was working), I recall 'pgrep -af cryosparc` yielding empty output.