How to update a worker's configuration (ssd path)

Hi, I installed a standalone version using the --nossd flag. Everything was going well until the 2D classification, where I needed an SSD (according to other discussions). So I partitioned the drive and tried to re-install. The output said

Worker will be registered with SSD cache location /localssd/dir
ERROR: This hostname is already registered! Remove it first.

I see that the SSD isn’t really registered, as a new 2D classification still stalls (“Waiting because resources are not available (SSD)”) and under Compute Configuration I see Cache path and Cache quota are empty.

So it looks like the already-used hostname is blocking the re-install with SSD. How can I remove it? Thanks for your help.

Sacha

Hi @AlekS,

To update your worker node’s configurations, please take a look at the “update” section of cryosparcw:

Essentially, you need to run:

  --worker <worker_hostname>
  --master <master_hostname>
  --port <port_num>
  --update
  --ssdpath <ssd_path>

Hi, thanks for the reply. Just to be clear: I have a single workstation, so I did the single workstation install. Should I now do the standalone worker install on the same machine?

Hi @AlekS,

If you’ve already installed cryoSPARC via the standalone instructions, there should be no need to reinstall cryosparc2’s worker again. If at some point you deleted the worker directory, then you can install it again using the Standalone Worker instructions.

Hi, I’m still not clear. I didn’t do the standalone install, I did the single workstation install. Is there some sort of --update option for the --standalone install?

Hi @AlekS,

The “standalone” install script simplifies the cryoSPARC installation by installing the master and worker packages on the same machine (i.e. the master_hostname and worker_hostname values are the same). In that way, when running the cryosparcw connect --update command, you just specify the --worker and --master args to be the same hostname. Let me know if you have any other questions.

Hi, thanks for following up on this.

I ran cryosparcw connect --update with the ssdpath specified and the output suggests that it worked. I also see the ssd path listed under Cache path in Instance Information. 2D classifications work with SSD disabled but still don’t work with SSD enabled (it says SSD not available). The directory has permissions to read and write.

What could the problem be?

Hey @AlekS,

Can you confirm you’re on the latest version of cryoSPARC (v2.13.2)? We released a bugfix a few releases ago that addressed a related issue.

Yes I updated to v2.13.2 immediately after the connect --update.

Hi @AlekS,

Can you try the connect command again, now that the instance has been updated? Ensure to specify --ssdpath.

That fixed it! I ran the connect command with --ssdpath specified, cycled cryosparcm start/stop and everything works now. Thanks again!