File type and movie import troubleshooting


I’m a new cryosparc user running v3.3.2+220518 on a single master-worker setup.
I’ve collected both Cryo-EM and negative stain data as .tiff images for my single particles. I do not have a gain of reference file but should be able to process my data without one (Gain reference file not available). When importing movies, the job would complete - but the movies would fail to import with the following error for all imported images:

AssertionError: Data file /home/owner/Desktop/TIFF images for reconstruction.tiff has only 1 frame - import as micrograph instead.

Since the images did not import successfully, I could not process my data. I figured the AssertionError was file type dependent so I converted all of my .TIFF images to an .mrc stack using the tif2mrc command in IMOD as follows: $PATH tif2mrc *tiff output.mrc. That seemed to do the trick. I was able to import the .mrc stack successfully. However, the image quality of the micrograph stack was significantly reduced compared to the individual .tiff images when viewed as .png files in the import movies > overview tab. I thought that this was due to image stacking of the .mrc file and that during subsequent steps, cryosparc would be able to de-convolve the image stack. With the .mrc file, I was able to motion correct, estimate CTF and blob pick without errors of any kind. Inspecting the outputs, it looks like the program is trying to analyze noise and is not correctly processing the single particles of each image.
If I open the input files as .tiff or .jpg in cryosparc or an imaging processing software respectively, I can clearly see the particles I’m looking for.

At this point, I’m not sure if the incorrect processing is file type/ conversion dependent or if cryosparc is having difficulty handling the file types I have been importing.

Additionally, I can’t figure out why I was able to motion correct, CTF estimate and blob pick with my data imported as a .mrc stack but cryosparc would fail during motion correction with the tutorial data I’ve previously tried to process (Traceback error when running tutorial data during CTF estimation step).

Thanks in advance for your help.

Are you sure that you collected movies and not micrographs? The error you see for the TIFF images is telling you that there’s only one frame, which would be surprising for a movie. Do they look correct if you use the “Import Micrographs” job instead of “Import Movies”?

Hello posertinlab,

Thanks for your help.

You’ve made me realize that I have to convert each .tiff image individually to an .mrc file then upload them as micrographs opposed to creating an .mrc stack.

I’ve done that with a few frames and it’s worked.