Ewald sphere correction not usable

Hi @team,
what a great pleasure to see the new features available, I immediately wanted to try some of them.
So far I was not able to use EWS correction during NU refinement, the job always crashes at beginning.

[CPU: 2.54 GB]   ====== Starting Refinement Iterations ======

[CPU: 2.54 GB]   ----------------------------- Start Iteration 0

[CPU: 2.54 GB]     Using Max Alignment Radius 12.614 (20.000A)

[CPU: 2.54 GB]     Auto batchsize: 2135 in each split

[CPU: 3.81 GB]     Minimizing over per-particle scale factor

[CPU: 3.81 GB]   Engine Started.

    [CPU: 1.64 GB]   Traceback (most recent call last):
      File "cryosparc_worker/cryosparc_compute/run.py", line 85, in cryosparc_compute.run.main
      File "cryosparc_worker/cryosparc_compute/jobs/refine/newrun.py", line 571, in cryosparc_compute.jobs.refine.newrun.run_homo_refine
      File "cryosparc_worker/cryosparc_compute/jobs/refine/newrun.py", line 524, in cryosparc_compute.jobs.refine.newrun.run_homo_refine.engine_work
      File "cryosparc_worker/cryosparc_compute/engine/newengine.py", line 2379, in cryosparc_compute.engine.newengine.process

I can exclude hardware issues, it’s neither running on nodes with A100, A40 or 2080Ti.
Any ideas?


Hi @tarek,

Apologies for this – Ewald sphere correction was only formally added to the Homogeneous reconstruction, homogeneous refinement, and CTF refinement jobs (it was a bug that these parameters appear on the non-uniform refinement job, which we will resolve in a patch).

Of course, you may still want to use the two in conjunction. Right now the best way to do that is to run non-uniform refinement without EWS enabled, and then use the output particles (and output FSC mask) as the inputs to a homogeneous reconstruction only job with EWS enabled. This would be similar to the tutorial workflow shown on our guide.



Thanks @mmclean for making that clear.