Error when updating from v3.3.1 to v3.3.2

When I updated to v3.3.2 from v3.3.1 from the web interface, it did not update the _worker directory properly so that internally there was a conflict and job submission was stopped. However, after I saved the *_database into a backup place, and then manually installed v3.3.2 into the same directory, I could not remotely log into the dashboard via port :39000 any more. The web server was hanging with no info in the window. I wonder if something was missing or was done incorrectly. Thanks for sharing your thoughts.


Hi @jiangq9992003 , if you have a decent copy of the database, why don’t you reinstall cryosparc in a new folder and then restore the database?

cryosparcm restore --file=my-database-backup

The database contains projects and users.
The only thing you will need to do after reinstalling is to be sure the workers/lines are also installed and they work :wink:

is a good idea if a recent backup generated by cryosparcm backup is available.
On the other hand, special precautions are required if cp, rsync, or similar command is used for backup. @jiangq9992003 Which backup method did you use. Was the cryoSPARC instance shut down at the time of the backup?

Thanks for your suggestions. The error happened when I started the upgrading online. I did not do the database backup the way you suggested. I reinstalled v3.3.2 and then move the database directory directly. It worked with the old database.
Today I encountered a different error when I tried to shut down and restart cryoSPARC after running for 3 weeks.
command_core: ERROR (spawn error).
Is there anything to do with the “out-of-memory” errors I have encountered in the past two days in 2D classification?
Thanks for your thoughts.

Please see

for a discussion of this problem and a possible resolution.

Thanks. After rebooting of the workstation, the problems went away.