Cryosparc3.1.0 update


I was using ver2.15.0 which was working fine. I decided to update it to ver3.1.0 and followed

Things “seemed to have” gone fine because I was able to log in and the version on the new instance showed up as the new ver3.1.0. But I tried to submit a job and then got an error message that the version on the worker node did not get update - its still 2.15.0 - somehow my worker node did not get updated.

I tried to follow: Version mismatch
But I kept on being thrown off because I couldn’t figure out where my downloads were going. I tried to go back to ver2.15.0 but then wasn’t really sure what I was doing. Currently however I am not being able to run cryosparc. When I run: cryosparcm start, I get:

Starting cryoSPARC System master process…
CryoSPARC is not already running.
database: started
command_core: ERROR (spawn error)

Then, I tried: cryosparcm status, and I get:

CryoSPARC System master node installed at
Current cryoSPARC version: v3.1.0

cryosparcm process status:

app STOPPED Not started
app_dev STOPPED Not started
command_core FATAL Exited too quickly (process log may have details)
command_rtp STOPPED Not started
command_vis STOPPED Not started
database RUNNING pid 7587, uptime 0:00:30
liveapp STOPPED Not started
liveapp_dev STOPPED Not started
watchdog_dev STOPPED Not started
webapp STOPPED Not started
webapp_dev STOPPED Not started

global config variables:

export CRYOSPARC_DB_PATH="/home/cryosparc_user/software/cryosparc/cryosparc2_database"

I tried to run: cryosparcm log command_core and I get:

Traceback (most recent call last):
File “”, line 1, in
ModuleNotFoundError: No module named ‘cryosparc_command’
Traceback (most recent call last):
File “”, line 1, in
ModuleNotFoundError: No module named ‘cryosparc_command’

This message just goes on and at the very end of the terminal display I get: “Waiting for data… (interrupt to abort)” I simply ctrl+c and q to get back to the terminal

I have tried: ps -ax | grep “supervisord” and then killed the PIDs with supervisord/cryosparc in their description.

Any suggestions on what to do here? (I am running Cuda V10.0.130)