Cryosparc 4.1.1 database issue

Hi, the cs instance was running on local GPU, all fine. No problems with updates from 3.x to 4.1.1. I did not use the workstation for few days and I come back to the database spawn error. Now, I used mongod command

/cryosparc/cryosparc_master/deps_bundle/external/mongodb/bin/mongod --dbpath /data/cryo/cryosparc_database --repair

to try and -repair the database, which usually works after deleting /tmp/mongod-xxxxx.sock and .lock files in database directory.

However, this time I got a huge prompt why the repair does not work. I will attach the text file to this message for your reference.

I also trued updating to 4.1.2 but similar problem persists.

Thank you and cheers

Deletion of “sock” and “lock” files is outside the usual operation of a CryoSPARC instance, and could either be a symptom or a cause for database malfunction.
mongod --repair does not restore corrupted data.
I recommend

  • identification and elimination of the database malfunction’s underlying cause(s)

Then either

  • restoration of a recent database backup


  • establishment of a fresh database with subsequent
    • reconnection of workers
    • re-creation of users
    • attachment of CryoSPARC projects

Hi, nothing I tried worked. I had to reinstall the cryosparc 4.1.2 and re-establish everything. Now, the new instance works without problems.

Thank you for your reply.