Changing CUDA version

I’d like to upgrade cryoSPARC from 2.9 to 2.11, and also update the version of CUDA that cryoSPARC uses. Currently we’re running cryoSPARC 2.9 with CUDA 9.2 I have the impression that cryoSPARC 2.11 supports CUDA 10.1. (It would be helpful if the supported CUDA versions were listed in the installation documentation).

When the worker is installed, the CUDA path is specified with “ --cudapath…”. Is there a way to change the cudapath so that after the upgrade cryoSPARC 2.11 will be pointed to CUDA 10.1?

Can I just change the setting of CRYOSPARC_CUDA_PATH in cryosparc2_worker/

UPDATE: I pointed the installation to CUDA 10.1 and it failed with the same error as when I pointed v. 2.8.3 to CUDA 10.1. So I guess 10.1 is still not supported. Reverting to CUDA 9.2 works.

Also, I tried to use Redhat Devtoolset v. 8, and that also gives an error at runtime, saying that only gcc up to version 7 is supported. It would be good if the documentation described which CUDA and gcc versions work, and it would also be good if these were automatically checked during installation. Discovering these prerequisites by trial and error is pretty time-consuming.

Matthew Cahn
Dept. of Molecular Biology
Princeton University

Thanks for the information.