After applying latest patch a prefix is added to the movie/micrograph names


since I applied the latest patch yesterday a unique identifier is added at the beginning of my movie and micrograph names upon import. This was not the case for imports I did earlier this week. Since I import both the movies and the micrographs this is causing a missmatch between movie and micrograph names.
Is this a new feature or a bug? Do other users have the same issue? Is there a quick temporary way to cut the suffix (like the cut suffix function during particle import).
Thank you in advance

I found this previous fix:

Cutting the prefix seems to help with this issue on the import command, however the latest patch does not have these options (options only exist to cut the suffix).

I should also add that I am seeing this pop up after pulling the latest patch to fix AssertionError issues we were having on our instance.

Hi @DMR,

Thank you for pointing this out. This issue will be fixed in the next patch. You will be able to not only cut the suffix of both the movie and micrograph name, but also the prefix in Import Micrographs in order to link the input movies and the imported micrographs together.

Hi, something like this, but for all import particles is happening now (latest version, latest patch)

CryoSPARC System master node installed at
Current cryoSPARC version: v3.3.1+211214

There is a numeric prefix for the imported particle (blob) files.

Is this intentional? Will it remain? From Scipion we need to do me matching and if so we need to distinguish if the prefix has been applied or not.

This issue still persists even after applying the latest patch. When importing aligned DW micrographs, the source file, e.g. 23aug16a_XXX-DW.mrc becomes 005202846645803362636_23aug16a_XXX-DW.mrc. Where is this prefix coming from?

thanks for your reply. Is there any option not to add this “unique identifier” or a way to remove it? this causes problems later.

Unfortunately, no, I’m afraid.

What sort of problems do you anticipate encountering? If it’s issues to do with star conversion and reassociating with RELION’s output, has the --strip-uid flag or you can remove them using regex in your text editor of choice.