Error in importing particle coordinates from relion to cryosparc

I have seen this topic been discussed in this forum and am really appreciate for the solution orangeboomerang posted previously. I tried to follow the solution but could not get it correctly.
Here is my situation: I imported the movies into cryosparc and did patch-motion and patch-ctf and want to try to re-extract the same set of particles in these images I picked in relion a while ago for re-process.

In Import Particles, I connected the exposures from patch-ctf, and specified the modified .star file (contains _rlnMicrographName #1, _rlnCoordinateX #2, _rlnCoordinateY #3), choose ignore raw data, and in the suffix to cut, I think I cutted it correctly from the end of each image file. But I still get the following error.
I am not sure whether it is because the front of the source micrograph filename has this extra ‘6521773161666237731_’. Can anyone give me some idea how to solve the problem?

[CPU: 192.9 MB]    Example source micrograph filename:
6521773161666237731_20191025_Jing_234_00000_Oct25_22.02.00

[CPU: 193.3 MB]    Example query micrograph filename:
20191025_Jing_234_00009_Oct25_22.04.51
[CPU: 193.3 MB]  Traceback (most recent call last):
 File "cryosparc2_master/cryosparc2_compute/run.py", line 85, in cryosparc2_compute.run.main
 File "cryosparc2_compute/jobs/imports/run.py", line 209, in run_import_particles
   assert qname in inv_index_source, "Could not find match for %s" % qname
AssertionError: Could not find match for 20191025_Jing_234_00009_Oct25_22.04.51

Hi @jliu,

This is actually a change we introduced in v2.15.0 where we added a unique identifier to the beginning of each micrograph name, which would ensure micrographs with similar names from different folders wouldn’t get overwritten. This is now technically a bug, as you pointed out there is a regression with the Import Particles job- I’ll make sure to add a “prefix cut” parameter which will allow you to remove that UID from the micrograph path, and you should be able to test via a Patch. I’ll keep this thread updated.

Hi @jliu,

I’ve created some patch files for the Import Particles job for you to test- the changes allow you to specify the number of characters to cut from the prefix of the base micrograph path from the input dataset, which will allow you to remove the extra 6521773161666237731_ from the beginning of the micrograph path. (e.g. enter “20” for the Length of input micrograph path prefix to cut parameter)

To implement this patch, download the run.py and build.py files from the following links:
(either download the files directly by clicking on them or use wget)
https://structura-assets.s3.amazonaws.com/import_particles_v2.15_locations_bugfix/build.py
https://structura-assets.s3.amazonaws.com/import_particles_v2.15_locations_bugfix/run.py

Once downloaded, on your master node, replace the following two files with these files.
cryosparc2_master/cryosparc2_compute/jobs/imports/build.py
cryosparc2_master/cryosparc2_compute/jobs/imports/run.py

Once replaced, restart cryoSPARC:
cryosparcm restart

After that, you should be able to create a brand new Import Particles job to see the new parameters, and you’ll be able to test the changes I just made. Please let me know how it goes!