3D Variability error (v3.1.0) GLIBC_2.18 not found

Hi All, I was trying to do 3D Variability using v3.1.0 (updated from v3.0.1), but got the following error. Any suggestions? Thanks.

Starting 3D Variability =====================
[CPU: 4.58 GB] Initial reconstruction 1 of 2
[CPU: 4.66 GB] batch 1 of 3486
[CPU: 4.44 GB] Traceback (most recent call last): 
File "cryosparc_worker/cryosparc_compute/run.py", line 84, in cryosparc_compute.run.main 
File "cryosparc_worker/cryosparc_compute/jobs/var3D/run.py", line 123, in cryosparc_compute.jobs.var3D.run.run 
File "cryosparc_worker/cryosparc_compute/engine/newengine.py", line 432, in cryosparc_compute.engine.newengine.EngineThread.preprocess_image_data 
File "cryosparc_worker/cryosparc_compute/engine/newcuda_kernels.py", line 5052, in cryosparc_compute.engine.newcuda_kernels.prepare_real 
File "cryosparc_worker/cryosparc_compute/engine/cuda_core.py", line 392, in cryosparc_compute.engine.cuda_core.context_dependent_memoize.wrapper 
File "cryosparc_worker/cryosparc_compute/engine/newcuda_kernels.py", line 4957, in cryosparc_compute.engine.newcuda_kernels.get_util_kernels 
File "/home/groups/xxx/cryosparc/cryosparc2_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/pycuda/compiler.py", line 291, in __init__ arch, code, cache_dir, include_dirs) 
File "/home/groups/xxx/cryosparc/cryosparc2_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/pycuda/compiler.py", line 254, in compile return compile_plain(source, options, keep, nvcc, cache_dir, target) 
File "/home/groups/xxx/cryosparc/cryosparc2_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/pycuda/compiler.py", line 137, in compile_plain 
stderr=stderr.decode("utf-8", "replace")) 
pycuda.driver.CompileError: nvcc compilation of /tmp/tmp30zi069w/kernel.cu failed [command: nvcc --cubin -arch sm_70 -I/home/groups/xxx/cryosparc/cryosparc2_worker/deps/anaconda/envs/cryosparc_worker_env/lib/python3.7/site-packages/pycuda/cuda kernel.cu] [stderr: cicc: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by /home/groups/xxx/cryosparc/cryosparc2_worker/cryosparc_compute/libs/libstdc++.so.6) ]

Hi @donghuachen,

CryoSPARC v3.1 has been re-released to include a fix for this bug.
See this post for update instructions:

Hi @stephan,

I tried this:
cryosparcm update --override

and still got the same error for 3D Variability.

Hi @stephan,

I went back to v3.0.1 and run 3D Variability for the same dataset, but no such error yet although the job is still running. Just for your reference.

Hi @donghuachen,

Sorry for the troubles, but after your job is run, can you try updating to v3.1 again? (cryosparcm update)

Hi @stephan,

After the job starts to run under v3.0.1, then do updating, that would kill the job?

Hi @stephan,

Editing to say that I had a major case of weekend brain and of course your patch works when Iā€™m updating correctly.

Thanks and appologies,

Hi @donghuachen,

Yes, if you start updating while your job is running, it will eventually fail (within about 5 minutes or so). Best to update once your jobs are complete.

Hi @NathanaelCaveney,

Glad to hear it! No worries at all :smiley:

1 Like

@donghuachen Can you please let us know once you have successfully updated to v3.1 and run a new job? Do you still get this error?


I just updated cryoSPARC from v3.0.1 to v3.1.0 to run 3D Variability. It seems to be working now without that error. Thanks so much!