ZeroDivisionError: float division by zero when running ab initio


I have been recently getting the following error when running ab initio model generation of a dataset with 66000 particles asking for 10 classes:

Traceback (most recent call last):
File “/datahdd/cryosparc/cryosparc-compute/”, line 318, in
cuda_devs = current_experiment_params[‘cuda_devs’])
File “/datahdd/cryosparc/cryosparc-compute/”, line 401, in abinit
File “/datahdd/cryosparc/cryosparc-compute/”, line 359, in heuristicsearches
doscale = doscale, ignore_dc = ignore_dc, cuda_workers = cuda_workers)
File “/datahdd/cryosparc/cryosparc-compute/”, line 245, in compute_Us
File “/datahdd/cryosparc/cryosparc-compute/”, line 214, in work
IW.load(D, C, 1.0/N_R, 1.0/N_S, 1.0,
ZeroDivisionError: float division by zero

The error always happens at around iteration 550, although the exact iteration at which the error takes place varies between runs.

I have tried also asking for 9 classes, but got the same error (also around iteration 550). It seems to be somehow similar to a previous issue (ZeroDivisionError: float division by zero)

Has anyone managed to get around this error without having to lower too much the number of classes?

Thanks in advance!

Hi Rafael,

Thanks for reporting this. The issue is a bug in cryoSPARC that we’re trying to diagnose. It doesn’t always happen (I’ve run 10+ class jobs successfuly before) but when it does, there is not yet a workaround. It’s high priority, as soon as we fix it, it’ll be deployed.


I’ve seen this too - in my case, it only happened late in the piece, once several classes had become entirely empty