WiredTiger error while updating


Recently the cryosparc webpage was not displaying and it was showing only the status bar which goes left and right. So Stopped cryosparc and updated to version 2.4.2. Now when I start cryosparc I get

database FATAL Exited too quickly (process log may have details)

error. Im sure no one else has permission to touch the installation director and no others instances were running. I tried to chmod and chown all directories. Also looked if any orphaned supervisord processes etc etc. Also there is no socks file in the /tmp.

I looked in to cryosparcm log database and it pointed to WiredTIger error.

2018-11-26T12:38:28.802+0100 E STORAGE [initandlisten] WiredTiger error (0) [1543232308:802365][29562:0x7f0e3d4f1d40], file:WiredTiger.wt, connection: WiredTiger.turtle: encountered an illegal file format or internal value
2018-11-26T12:38:28.802+0100 E STORAGE [initandlisten] WiredTiger error (-31804) [1543232308:802418][29562:0x7f0e3d4f1d40], file:WiredTiger.wt, connection: the process must exit and restart: WT_PANIC: WiredTiger library panic

It would be great help if the community could help with the following

  1. Is there a way to recover the database ? or is it completely corrupt.

  2. if now way to recover the database is it possible to import them from the Project directories.

  3. In case if I have to start from ( if 1 and 2 is not possible ) , Do I need to completely reinstall or tell the cryosparc to use a new database.

Thanks in advance for your time and help.

best regards


We couldnt fix it, so I tried to install a fresh cryosparc ( after moving the old and made new folder name and started clean). When I do the installation everything is OK but its trying to start, its giving database: ERROR (spawn error).

I checked for any instances of cryosparc running. Also looked in /tmp for sock file. All looked clean ( ps -ef | grep cryosparc was empty).

But when I did cryosparcm log database its complaining that it couldnt lock the file. ERROR is below

Cryosparc/2.45/cryosparc2_database/mongod.lock No locks available. Is a mongod instance already running?

I havd restarted the computer and did a clean fresh installation and the error still persist. Is there any residual sock file somewhere hindering it ?? I am running as a user and checked all possible areas ( /tmp for example).

We are happy to receive any help in this regards.