Web app startup error: listen EADDRINUSE

It is the first time I use cryosparc, and it seems installed successfully. However, It cannot open in web when I start cryosparc.

The cryosparcm status is show as following:

CryoSPARC System master node installed at
Current cryoSPARC version: v3.2.0

CryoSPARC process status:

app RUNNING pid 205588, uptime 0:00:53
app_dev STOPPED Not started
command_core RUNNING pid 205508, uptime 0:01:08
command_rtp RUNNING pid 205534, uptime 0:01:02
command_vis RUNNING pid 205529, uptime 0:01:04
database RUNNING pid 205397, uptime 0:01:11
liveapp RUNNING pid 205614, uptime 0:00:51
liveapp_dev STOPPED Not started
webapp RUNNING pid 206119, uptime 0:00:02
webapp_dev STOPPED Not started

global config variables:

export CRYOSPARC_DB_PATH="/home/***/cryosparc/cryosparc_database"

and when I open a new webpage with “http://localhost:39000”, it shows “The connection was reset” and can’t be opened.

when check with cryosparcm log webapp, it shows:

Error: listen EADDRINUSE
    at Object._errnoException (util.js:1022:11)
    at _exceptionWithHostPort (util.js:1044:20)
    at Server.setupListenHandle [as _listen2] (net.js:1351:14)
    at listenInCluster (net.js:1392:12)
    at doListen (net.js:1501:7)
    at _combinedTickCallback (internal/process/next_tick.js:141:11)
    at process._tickDomainCallback (internal/process/next_tick.js:218:9)
(node:181051) DeprecationWarning: current Server Discovery and Monitoring engine is deprecated, and will be removed in a future version. To use the new Server Discover and Monitoring engine, pass option { useUnifiedTopology: true } to the MongoClient constructor.
ESC[32mReady to serve GridFSESC[39m
      throw er; // Unhandled 'error' event

Thanks for your help.

Hi @Tang,

It looks like the web application could not start due to the port 39000 already being used by the system.

  1. Ensure cryoSPARC is turned off:
    cryosparcm stop

  2. Then, ensure no zombie processes are still running. Kill the processes if they are.

ps -ax | grep “supervisord” (kill only the process that is running from your cryosparc2 install)
ps -ax | grep “cryosparc2_command” (kill all the matching processes related to your cryosparc2
ps -ax | grep “mongod” (kill only the process running your cryosparc2 database)

e.g. kill 82681

  1. Remove the socket file inside the /tmp folder


  1. Start cryoSPARC:
    cryosparcm start
    cryosparcm status

That should solve the problem, but if it doesn’t please take a look at this post: OtherError: "node is not in primary or recovering state" when connecting cluster

- Suhail

Hi Suhail,
Thank you for your reply. unfortunately, they are not work. I have tried what you suggested, it shows as follows:

172 zeus:/home/tangq3/cryosparc/cryosparc_master/bin% ps -ax | grep “supervisord”
124969 pts/0 S+ 0:00 grep --color=auto “supervisord”
173 zeus:/home/tangq3/cryosparc/cryosparc_master/bin% kill 124969
124969: No such process
174 zeus:/home/tangq3/cryosparc/cryosparc_master/bin% ps -ax | grep “cryosparc2_command”
125118 pts/0 S+ 0:00 grep --color=auto “cryosparc2_command”
175 zeus:/home/tangq3/cryosparc/cryosparc_master/bin% kill 125118
125118: No such process
176 zeus:/home/tangq3/cryosparc/cryosparc_master/bin% ps -ax | grep “mongod”
125250 pts/0 S+ 0:00 grep --color=auto “mongod”
177 zeus:/home/tangq3/cryosparc/cryosparc_master/bin% kill 125250
125250: No such process
178 zeus:/home/tangq3/cryosparc/cryosparc_master/bin% cd …
179 zeus:/home/tangq3/cryosparc/cryosparc_master% cd …
180 zeus:/home/tangq3/cryosparc% cd ././tmp/
././tmp/: No such file or directory.
It seems no zombie processes I can kill and I can’t find any /tmp folder. Could you please tell me the location of /tmp folder?

I also tried to delete "export CRYOSPARC_MASTER_HOSTNAME=“zeus” in the config.sh file, still not work.

Thank you for your help.

Hi Suhail,
I just find the /tmp folder and delete the /tmp/cryosparc-supervisor...XXX.sock file, now it shows:

103 zeus:/home/tangq3/cryosparc/cryosparc_master/bin% cryosparcm restart
CryoSPARC is running.
Stopping cryoSPARC
Shut down
Starting cryoSPARC System master process…
CryoSPARC is not already running.
database: ERROR (spawn error)

new questions appear. Could you also figure out how to solve it, please?
Thank you.

Hi @Tang,

Please report the output of the following command: cryosparcm log database