Volume Tools job: resample error?

Hi! :slight_smile:

This could probably be also a good question for the Chimera forum, but I try it here first.

Today I was struggling with something that usually would take me 15 minutes to do: mask creation.
I have after long time realized what was the problem. I created a simulated map from model using Chimera molmap with the onGrid option to have the same box size as the reconstruction map from cryoSPARC. I then imported the new volume on cryoSPARC successfully and attempted to use Volume Tools job to covert map to mask.

I was then surprised by this error:

[CPU: 223.9 MB] Traceback (most recent call last):
File “cryosparc_worker/cryosparc_compute/run.py”, line 85, in cryosparc_compute.run.main
File “/home/angr5008/Software/cryosparc/cryosparc_worker/cryosparc_compute/jobs/utilities/run_volume_tools.py”, line 90, in run
vol_f = fourier.fft(vol)
File “/home/angr5008/Software/cryosparc/cryosparc_worker/cryosparc_compute/fourier.py”, line 110, in fft
return fftcenter3(x, fft_threads)
File “/home/angr5008/Software/cryosparc/cryosparc_worker/cryosparc_compute/fourier.py”, line 69, in fftcenter3
assert all([d%2 == 0 for d in vol.shape])
AssertionError

I tried to figure the error, but it is not very self-explanatory.

I then returned to chimera and performed a vop resample onGrid command on the simulated map I originally imported on cryoSPARC. Turns out that when I followed this ‘traditional’ way there was no error.
Why does cryoSPARC require resampled volumes? At least in real space, the volume looked as it should (right box size, centered), but I am curious to understand the concept/reason for resampling, especially because Volume tools job should be able to resample the volume right?

Cheers,
André

It doesn’t - I use molmap with ongrid all the time for exactly the same thing and it works fine. There must be some issue more specific to this particular map

Thanks @olibclarke, your vast experience is always valuable and saving me :slight_smile:

Hummm… very ‘unusual’, I see. Good that I was simply not satisfied that vop resample worked.
Any ideas about what I could further explore? Anything I can provide the community that can be helpful, just let me know.

These lines in the log indicate that at least one of the input volume’s dimensions was not divisible by 2, which caused the job to fail.