Version Mismatch after update

I just ran the update for v2.4.6 and my master updated just fine, but for some reason the worker update failed. So I pulled the new worker.tar.gz and did the update as described in the terminal. However, now cryosparc says the master is running v2.4.6 and worker running v2.4.2. I tried doing a fresh pull of both master and worker and just did a ‘fresh’ install, but still am seeing the same issue. Anybody see this before or have a way for me to specifically update the worker to match? I’m running a standalone config.

I’m having the same problem with a standalone installation.

cryosparcm update

Master running v2.4.6, worker running v2.4.0

Traceback (most recent call last):
File “cryosparc2_worker/cryosparc2_compute/”, line 43, in
AssertionError: Version mismatch! Worker and master versions are not the same. Please update.

removed worker and master directories
downloaded new packages
reinstalled following the standalone instructions

Master running v2.4.6, worker running v2.4.6

Additional details:
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2017 NVIDIA Corporation
Built on Fri_Nov__3_21:07:56_CDT_2017
Cuda compilation tools, release 9.1, V9.1.85

cryosparcm restart
CryoSPARC is running.
Stopping cryosparc.
command_proxy: stopped
command_vis: stopped
webapp: stopped
command_core: stopped
database: stopped
Shut down
Starting cryoSPARC System master process…
CryoSPARC is not already running.
database: started
command_core: started
cryosparc command core startup complete.
command_vis: started
command_proxy: started
webapp: started

CryoSPARC master started.
From this machine, access the webapp at
From other machines on the network, access at

Startup can take several minutes. Point your browser to the address
and refresh until you see the cryoSPARC web interface.

cryosparcm status

CryoSPARC System master node installed at
Current cryoSPARC version: v2.4.6

cryosparcm process status:

command_core RUNNING pid 4773, uptime 0:01:28
command_proxy RUNNING pid 4803, uptime 0:01:24
command_vis RUNNING pid 4792, uptime 0:01:26
database RUNNING pid 3623, uptime 0:01:31
watchdog_dev STOPPED Not started
webapp RUNNING pid 6081, uptime 0:01:23
webapp_dev STOPPED Not started

global config variables:

export CRYOSPARC_DB_PATH=“x/progs/cryosparc2/cryosparc2_database”

We also faced the same problem on a standalone installation. Any ideas?

What I ended up doing was deleting my cryosparc_master and worker folder. Doing a fresh install. I then got an error that I was able to fix using the below steps:

The error originates from an orphaned process during the update or having multiple cryosparc installations running on the same machine. For me it was the orphaned process.

After getting a fresh install I ran ‘cryosparcm stop’ to make sure the program thought nothing was running.
Then ran ‘ps -ax | grep “supervisord”’ to see if any cryosparc processes were running. I found 1 was still there so I killed that process and when I ran ‘cryosparcm start’ the program started as before

I got the same issue. After updating to v2.4.6, the version of master was 2.4.6 while worker was 2.4.0. I could solve this issue by “updating” to older version ($ cryosparcm update --version=v2.4.2).