ValueError: could not broadcast input array from shape (128,128) into shape (300,300)

Dear Cryosparc team
I have been using Cryosparc recently and i have encountered a problem during refinement with the below error
ValueError: could not broadcast input array from shape (128,128) into shape (300,300)

cryoSPARC v3.1 is the version
and my box size is 300

I have tried to downscale the input volume to 128 and restarted and still the error persists with the refinement. I would appreciate your help to resolve it.

The details of the error is below

[CPU: 1.42 GB]   Traceback (most recent call last):
  File "/opt/development/cryosparc_3.1/cryosparc_worker/cryosparc_compute/jobs/", line 1726, in run_with_except_hook
    run_old(*args, **kw)
  File "cryosparc_worker/cryosparc_compute/engine/", line 130, in
  File "cryosparc_worker/cryosparc_compute/engine/", line 131, in
  File "cryosparc_worker/cryosparc_compute/engine/", line 1027, in
  File "cryosparc_worker/cryosparc_compute/engine/", line 87, in cryosparc_compute.engine.engine.EngineThread.load_image_data_gpu
ValueError: could not broadcast input array from shape (128,128) into shape (300,300)


Hi Barathy,
Are you using an ab initio reconstruction from the same exact set of particles (no bin change) as your input volume for refinement?

Hi Aaron
I used a subset of particle from Heterogenous refinement for Non uniform refinement for this particular job. Most of my jobs including first 2d classification from all the particles also show this error when I tried to repeat 2D with old settings and Input, So i m bit Puzzled!


@vd_barathy, Can you please let us know the exact set of steps you did to get to this stage and any error messages/tracebacks you received along the way? We are especially interested to know at what point the particles box size changed.

Thanks for your response,

first error message i have encountered was during heterogenous refinement, and I always used original box size of 300.
The steps before were 1. particles imported from relion after ctf estimation.
2. 2d classification,
3. ab intio model generation
4. Heterogenous refinement
5. Non uniform refinement
6. Heterogenous refinement again to remove bad particles (error appeared in this step)

When i started the run my input particles were wrong so i killed the run when it was copying the particles to cache/ssd. And when i restarted with correct particle stack this error appeared.

FYI- we have also tried to clear the particles from cache and did not help.