V3.0 install "Unknown option: --initial_name"

Hi all,
while the cryosparc update v3.0.0 on 5 of 6 computers worked fine, one update wiped the database (please backup as recommended) and somewhat killed my anaconda environment.
Warning: conda environment not found; this indicates that a cryoSPARC installation is either incomplete or in progress
Nothing conda related in .bashrc, and everything conda related deactivated using:

conda deactivate
unset _CE_CONDA

Still giving me a
Warning: conda environment not found; this indicates that a cryoSPARC installation is either incomplete or in progress

So I did a clean install and noticed that the flags now act up
./install.sh --standalone --license $LICENSE_ID --worker_path /my/worker/path--cudapath /usr/local/cuda --ssdpath /my/ssd/path/ --initial_name "Daniel Lastname" --initial_email "my@email" --initial_password "my_password"
results in a
Unknown option: --initial_name
When I work around it using the direct assignments from install.sh
The installation runs through, however, upon the first start CryoSparc gives me
Creating the initial cryoSPARC user…
Improper usage.

So I created the username manually using
./cryosparcm createuser --email "my@email" --password "my_password" --username "Daniel" --firstname "Daniel" --lastname "Lastname"
And I can log into the web interface.

Has the --initial_name flag changed in v3.0.0 or is my system now really messed up?

I’m having the same issues with clean install always returning “Unknown option: --initial_name”

Hi @mannda, cryoSPARC v3 includes its own embedded conda installation and conda environment. Are you saying that updating to cryoSPARC affected your own previously-installed conda environment?

You may see the Warning: conda environment not found; this indicates that a cryoSPARC installation is either incomplete or in progress during the update but this should be gone after the install completes. The clean install should fix it, as you’ve done.

The interface for creating a new user did change but the latest docs aren’t live yet, I’ll post the updates shortly.

Latest installation command instructions up here: https://guide.cryosparc.com/setup-configuration-and-management/how-to-download-install-and-configure/downloading-and-installing-cryosparc#install-the-cryosparc_master-package

Apologies for the mixup!


Hey @nfrasser, I’m not sure what happened to the conda env, it’s working fine now with the clean install. My main point was the --initial_name flag; thanks for the quick clarification and the update of the documentation.

Many hearts from Germany for including helical processing!


Hi @nfrasser

Follow this updated instruction, my installation has reported an error as follow:
Any suggestion? Thanks a lot!


The installer will now download, install and connect the worker
package on this machine. The worker package will allow cryoSPARC
to run compute jobs.

Starting cryoSPARC…

Starting cryoSPARC System master process…
CryoSPARC is already running.
If you would like to restart, use cryosparcm restart

Creating the initial cryoSPARC user…

Improper usage

Hi @zjr, looks like the installation failed to create the initial user. Looking into this now.

In the mean time, you can create the initial user manually with the cryosparcm createuser command. See instructions here: https://guide.cryosparc.com/setup-configuration-and-management/management-and-monitoring/cryosparcm#cryosparcm-createuser

Hi @nfrasser
Thanks! That works! It is odd, I have include all the user information in the installation but they got ignored…

Same issue here. Although this workaround does help in creating a user, the error actually happens even before installing the worker node. And because of that, there are no lanes showing up when the job is queued. Tried reinstalling from scratch several times and have run into the same issue every time. Not sure what is going on.

Hi @vamsee,

We’ve updated the packages to include a fix for the createuser function- you should be able to re-download and re-do the single workstation installation.

1 Like

Will try and report back

I am having a similar problem with “unknown option” when trying to run ./install.sh. I have pasted my installation commands below below.
$LICENSE_ID is defined -> echo $LICENSE_ID shows my license code. It is the code I have used for earlier versions. (A hard disk failure has required me to reinstall from scratch rather than update).

I get "Unkown option: --cudapath when I run the following:

./install.sh    --standalone \
--license $LICENSE_ID \
--cudapath /usr/local/cuda-10.2 \
--ssdpath /SSD-2TB/scratch         \
--initial_email "matthew.wilce@monash.edu" \
--initial_password "Password123" \
--initial_username "mwilce" \
--initial_firstname "matthew" \
--initial_lastname "wilce"  \
--worker_path /SSD2/programs/cryosparc-v2.15/cryosparc_worker

Does anyone have any ideas.


Hi @mwilce,

Can you try moving the --license $LICENSE_ID arg lower down, to test if there is something wrong with the value of the variable?

I tried moving the --license $LICENSE_ID arg lower down and this didn’t help. I still get Unknown option:


Hi @mwilce,

Is it possible that your LICENSE_ID variable has any weird characters in it? Can you try wrapping it in quotes?

Hi Stephan,
back after some leave last week…

I tried wrapping the LICENSE_ID in quotes but still the same problem. Perhaps a way to confirm a license issue would be to request a new license and see if this fixes the problem?