V2 cannot import bz2 compressed movies

Common fields:

mscope_params/accel_kv : set([300.0])

mscope_params/cs_mm : set([2.7])

mscope_params/total_dose_e_per_A2 : set([37.0])

movie_blob/psize_A :  set([0.54000002])

  movie_blob/shape :  [  50 7420 7676]


Making example plots…

Reading file…

Traceback (most recent call last):
File “cryosparc2_master/cryosparc2_compute/run.py”, line 78, in cryosparc2_compute.run.main
File “cryosparc2_compute/jobs/imports/run.py”, line 570, in run_import_movies_or_micrographs
hdr, frames = mrcbz2.load_mrcbz2_pbzip2(abs_path)
File “cryosparc2_compute/blobio/mrcbz2.py”, line 38, in load_mrcbz2_pbzip2
frames = n.frombuffer(stdout, dtype=n.uint16, count=nxnynz, offset=256*4).reshape(nz, ny, nx)
ValueError: buffer is smaller than requested size

Hi @istv01, can you describe the movies in question? This generally does work.
Could there be one file in the stack of movies that is corrupt/truncated?

These are Krios movies, 50 frames per movie. Just tried to import a larger number of them - same error.