Using imported particle stack from Relion - Error

Hi all,

I am having issues using an imported particle stack.

Here’s the general workflow:

  • Preprocessing and 2D classification in CryoSPARC
  • make star file using pyem
  • run 3D classification in Relion
  • Subset selection of the best class
  • Import particle stack to cryoSPARC: import only the star file, connect to the original preprocessed micrographs

So far so good, to now use this subset of particles for homogeneous refinement, I connect the imported particles, then add the blob from the original cryoSPARC extraction job, connect initial model and run.

Here’s the error I get:

Any help would be appreciated. Thanks!

Hi @twg,

Can you let us know:

  • the cryoSPARC version
  • did the workflow work correctly before upgrading?
  • are there any messages in the import particles job, and does the output contain the expected number of particles?

Hi @apunjani,

All of it was done in 2.15.0.

The import particle job worked fine I think and the number of particles shown is correct:

@twg can you send also a screenshot of the “outputs” tab of the import job? Specifically to see whether the imported particles also have “blob” and “location” information

Also, can you try to run an extraction job, using the imported particles and the original micrographs?

@apunjani, here’s the output:

I knew that the blob was missing that’s why I tried to connect the blob output from the original extraction job in cryoSPARC to the refinement runs.

Also, the extraction job runs! However, because the imported particles are downsampled to half the box size/double the pixel size, the extracted particles seem off center.

Thanks for all your help!

1 Like