User not found after moving database

I was getting the error message:
The disk where the cryoSPARC database is installed has less than 5GB of free space
therefore, I moved the database to the zpool on my machine, where there is space.

I changed the path of the database in cryosparc_master and started cryoSPARC. There was no error upon starting cryoSPARC, however I am getting a user not found error when trying to login to the webapp.

I tried checking the list of users, and none show up. I also tried making a new user as below:
cryosparcm createuser --email “user@organization” --password “initial-password” --username “myuser” --firstname “John” --lastname “Doe”
but this also hasn’t worked.

Could someone help please?

Anokhi Shah
Day lab, University of Manchester

Welcome to the forum @AnokhiShah.

Please can you provide additional information about the situation:
Was the cryoSPARC instance shutdown prior to moving the database?
With which commands did you move the database?
Are the new database directory and its contents owned by the Linux user that runs the cryoSPARC processes?
Does $CRYOSPARC_DB_PATH directly contain the moved files, not the old database directory PLUS files that were newly initialized because the database engine didn’t find the expected files directly under $CRYOSPARC_DB_PATH?
How did cryosparcm createuser [...] fail?

Thanks for the reply @wtempel.

I’ll do my best to answer your questions. The linux operating system and cryoSPARC is new to me so apologies if I don’t answer everything.

To move the database I actually dragged and dropped the folder. I found the help page suggesting to use rsync after I had already done that.

The database was originally within a separate cryosparc user which I have access to as admin. I moved it to the zpool which has a symbolic link within my personal user space. So I think the answer is yes, the contents are owned by the Linux user that runs the processes.

The $CRYOSPARC_DB_PATH directory was originally:
home/cryosparc/cryosparc/cryosparc_master (as the user it was in was called cryosparc). I changed it to home/myusername/zraidstorage/folder1/cryosparc_master
using the nano config.sh ^\

The actual cryosparc_database contains collection and index files. How would I be able to tell if these are old files plus newly initialised files?

The cryosparcm create user didnt do anything it just gave a new line with <

Thanks again for the help.

Based on the description of file moves so far and the apparent involvement of multiple Linux accounts (your personal account, the “separate cryosparc user” account and, possibly, the root account), I am uncertain about the current state of the cryoSPARC instance.
It is possible that file ownerships were modified during the move of the database, which alone could “break” the installation.
Additionally, the values given for CRYOSPARC_DB_PATH appear unusual (and possibly incorrect) in that they are lacking a leading (and functionally significant) “/” character and they are ending in cryosparc_master. The latter suggests the location of the cryoSPARC master programs, not the location of the database.
Depending on whether the database already contained important information at the time of the move, you may decide to either:

  • seek the the help of an experienced Linux user who is also familiar with cryoSPARC documentation to restore the current installation to a functional state or
  • permanently retire the current installation (to ensure it will not interfere with the proposed new installation) and:
    • ensure the old instance is no longer running:
      • cryosparcm stop
      • terminate possible remaining processes related to the old instance. You may follow instructions in this post, except you should not run cryosparcm start at this point.
    • carefully decide on the installation and database ownership and paths
    • reinstall the software
    • if needed, import existing project directories to the new cryoSPARC instance
1 Like

@wtempel Thank you for the advice.
As an update, I managed to restore access to users by using the rsync command in the documentation to move the database back to where it originally was. I suppose that means the problem was because I moved the database to another user which as you mentioned caused some issues with the instance.

Because of this, as I have a storage issue where my instance is installed, would you recommend migrating the entire install, rather than just the database?

Considering that logs written to cryosparc_master/run and a possible software upgrade may increase the storage “footprint” of your installation, it may be wise to migrate the entire installation to larger storage.

1 Like