User creation v2.15.0

New installation of 2.15.0 on an Ubuntu 20.04 platform.

Found GUI for creation of new users, Admin sub menu at the bottom right corner of the screen.

Provided the “token” to the user who used the GUI “new account” button, but clicking create account doesn’t seem to do anything.

The new user attempting password recovery also does not work, even when provided with the password recovery token.

I must be doing something systemically wrong, but I don’t know what.

Also - How do I delete test users created as a side effect of this process.
thank you,

@BrianCuttler we have seen this behaviour before, so not sure if you are doing anything wrong. We notice when this happens, running cryosparcm status will report “cryosparcm is not running.”, even though it is.

We usually resort to restarting cryosparcm or to add the user manually when we encounter this:

cryosparcm createuser --email <email_address> --password <password> --name <username>

To remove a user:

$ cryosparcm icli
Python 2.7.15 |Anaconda, Inc.| (default, Oct 10 2018, 21:32:13) 
Type "copyright", "credits" or "license" for more information.

IPython 5.1.0 -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help      -> Python's own help system.
object?   -> Details about 'object', use 'object??' for extra details.
 connecting to ...
 cli, rtp, db, gfs and tools ready to use

In [1]: db['users'].delete_one({'emails.0.address': '<email address>' })

Kind regards.



Thank you for your quick reply.

While cryosparc status had reported it as running, I did restart it.

The user remove command worked wonderfully, and the cli command to add a user worked as expected. I had tried that command last night, but if there was some conflict with the web creation of the account and the command line creation, the removal allowed a clean start.

Working as you described, we can now move forward with the addition of users.

many thanks,

We have this issue also and it seems to be related to Chrome and maybe PC.
If you use Safari and a Mac, you can register successfully and the create account button should work.
You can then go back to Chrome to do all your processing.
@apunjani, have you noticed this before? Have any ideas why this happens?


Thank you, will share with cryosparc admin, I’m just the OS/install guy, not the science guy.

I don’t see how to mark this closed/resolved…

Hi everyone,

The create account and reset password forms do not seem to work in certain network environments if you’re using Chrome. I’d suggest trying Firefox or Safari to get around this via the UI, or using the command-line as posted above.

We’re working on a fix for Chrome, but in the meantime you can try SSH-tunneling/port-forwarding as connecting to the web app via this method seems to resolve the unresponsive form issue.