Update 3.1 to 3.2 version mismatch


I just re installed new version of CS 3.2 and migrated the old database. When I restarted the CS, it started fine and working alright.
However, when I try to run a 2D job it says:

[CPU: 81.6 MB] Traceback (most recent call last):
File “cryosparc_worker/cryosparc_compute/run.py”, line 46, in cryosparc_compute.run.main
AssertionError: Version mismatch! Worker version (v3.1.0) and Master version (v3.2.0) are not the same. Please update.

I tried

bin/cryosparcw update

and it does not help.

[user@c101030 cryosparc_worker]$ bin/cryosparcw update
Updating... checking versions
Current version v3.2.0 - New version v3.2.0
Already up to date

But when I tried to rollback to v3.1, I’m stuck with

Starting cryoSPARC System master process…

CryoSPARC is not already running.

database: started

command_core: ERROR (spawn error)

Please help me out here with the new update. Seems like everything crashed.
Thank you

Hey @diffracteD, it sounds like the version mismatch may have happened because the path to the worker changed when you reinstalled (cryosparc_worker instead of the previous cryosparc2_worker).

I recommend upgrading the master to v3.2 and re-connecting the worker like this:

  1. Restart your machine to make sure no extraneous cryoSPARC processes are running
  2. Start cryoSPARC with cryosparcm start
  3. Run cryosparcm update --override to update to v3.2 if you haven’t already
  4. Open the cryoSPARC interface, go to Resources > Instance information. Look for the scheduler lane where the jobs are failing and note the name (e.g., cryoem1 in the following example)
  5. In a command line, enter the following command to remove the scheduler lane:
    cryosparcm cli "remove_scheduler_lane('LANE_NAME_HERE')"
    Substitute LANE_NAME_HERE with your lane
  6. Again via command-line, navigate to the newly installed worker directory
  7. Connect the worker to your master with the bin/cryosparcw connect command (reference here). The command will look something like this:
    cd cryosparc_worker
    cryosparcw connect \
        --worker WORKER_HOSTNAME_HERE \
        --master MASTER_HOSTNAME_HERE \
        --port 39000 \
        --lane LANE_NAME_HERE \
        --ssdpath /path/to/ssd \
    If are on a workstation, WORKER_HOSTNAME_HERE and MASTER_HOSTNAME_HERE may both be localhost. If you have a master/worker system with multiple machines, they should be the network hostnames of the master and worker machine. Be sure to use the appropriate base port.

Let me know if you have any trouble with that. Please send me the output of the following commands along with any other errors you get:

cryosparcm status
cryosparcm log command_core | tail -n 500

Also send me a screenshot of the entire Resources > Instance Information page.

1 Like

Sorry @nfrasser for delayed response.
I had to re-install the new version as CS is the major pipeline our lab uses for processing. I can not re-initiate the old version now as people are using the current version. But yes, we did lose a lot of processed stuffs while updating.