Unknown option: --license

Hi experts, Im new to cryosparc and keep having Unknown option: --license
Im using the command below, copy-paste license code in the section of --license licensecode
I just got my license today and tried echo and curl to verify that the license is valid.
Could anybody help me on this issue please? Thanks a lot!

./install.sh --standalone \
             --license licensecode \
             --cudapath /usr/local/cuda-11.8 \ 
             --ssdpath /tmp \ 
             --initial_email XX@outlook.com \ 
             --initial_password 'XXXX' \ 
             --initial_username 'XXXX' \ 
             --initial_firstname 'XXXX' \ 
             --initial_lastname 'XXXX' \ 
             --worker_path /home/kc/Desktop \ 
             --port 39000

I tried all I can imagine but still unkonwn option: --license

Could it be the problem that this is a new license that I just got today?

Welcome to the forum @Kai_Y.
Unless you downloaded CryoSPARC before November 8, 2023 or specifically downloaded packages for a CryoSPARC version older than 4.4, please can you try the installation omitting the

--cudapath /usr/local/cuda-11.8 \ 

line from the installation command.
Please:

  • Let us know the link for any documentation that still lists the install.sh --cudapath parameter, which should not be used for CryoSPARC v4.4+.
  • In case the installation still fails: Send me a private message with screenshots from your terminal that shows the actual installation command and error message. In the installation command, you may omit the --initial_password parameter; you will be prompted to define a password.

Hi @wtempel , thanks a lot for your advice, I did use an old version that I downloaded before, Im trying lastest version with a new license right now. May I ask how to set ssdpath? I was told to use --ssdpath /tmp but have no idea how should I set this ssdpath. Thanks!

Hi @wtempel , I just tried lastest version of cryosparc, used curl command to download. And I still have the unknown option --license problem, below is my terminal screenshot and my command:

I sent my terminal screenshot to your with private message

./install.sh --standalone \ –license $LICENSE_ID \ –worker_path /home/kc/Desktop \ –ssdpath /tmp \ –initial_email “email” \ –initial_password “PASSWORD” \ –initial_username “name” \ –initial_firstname “name” \ –initial_lastname “name” \ –port 39000

Hi @wtempel , I also tried this and received the “success:ture”, but still unkonwn option: --license when I use “./install.sh” to install

[kc@localhost cryosparc_master]$ export LICENSE_ID=$LICENSE_ID

[kc@localhost cryosparc_master]$ curl https://get.cryosparc.com/checklicenseexists/$LICENSE_ID

{“success”: true}

If you type this command in a single line, you may want to omit all the \ (backslash) characters from the command.