Trouble with updating cryoSPARC


I might be silly and be missing something obvious but I am having trouble updating to the newest version of cryoSPARC. I cannot find the button (update) on the main page. I have seen it there before in previous updates, but now it is not there. I have tried updating from the terminal, but without any success. I have moved the installation folder (with the data output folder) recently, but i don’t know if that have anything to do with it. Anyone know how to fix this, I really want to try out the 2d classification.


Hi @Jens, you should be able to fix this by going into the file in your cryoSPARC installation directory, and manually changing the paths that pointed to the old installation directory to point to the new one. There may be more than one line that needs to be edited in the file. Please let us know if that fixes the problem. Thanks!


I tried changing the paths for the the following to the new (these were the ones which had a path associated with them):


After I did the changes to the new directory, I re-opened cryoSPARC. I could tell something had happened because it changed which experiments I could see (I think I had not switched the installation location before, but only the data output, so now it showed me the original experiments I had, before I copied the content to the new installation folder). However I did not get the update-button to appear on the main-page of cryoSPARC though.