Trouble launching new TRVP example dataset


I have recently installed cryoSPARC and I am trying to get it working. The guide suggests to download and troubleshoot the program with the example TRVP1 dataset.

I have performed the following commands-
[cryosparc start]
[cryosparc fetchexamples]

Then I follow the guide

Create the dataset in cryoSPARC:
    Click on the ‘Experiments’ page, then click ‘Configure’ and ‘Add New File Set’.
    Name the Dataset ‘TRPV1’ by clicking on ‘New Dataset’ and modifying the text.
    For Meta Data File, click ‘Browse Bulk Files’. From the dropdown menu, click on on the ‘example_datasets’ folder and select the .star file.
    For Image Data File, click click ‘Browse Bulk Files’. From the dropdown menu, click on on the ‘example_datasets’ folder and select the .mrc file.
    In this example, the .star file does not contain a pixel size and therefore must be entered. Scroll down to the (microscope) ‘Parameters’ section and manually enter the Pixel Size as 1.2156.

Click ‘Visualize’ and ‘Launch’ to have cryoSPARC load and display the data.

And get the following output-

Launched job Kgvkt4mDNqzTXgj3W
License is valid.
Job Type: visualize_dataset Job ID: Kgvkt4mDNqzTXgj3W
Assigned Slots: RAM: None GPU: None
Visualizing Dataset ID oFsDcGzpwZp4gNQnM
Loading Dataset …
---- Loading File Set. Type: star Path: /usr/local/cryosparc/run/bulk/./example_data/EMPIAR10005/
Loaded meta data for 35645 images.
Could not find file tv1.mrcs with base /usr/local/cryosparc/run/bulk/./example_data/EMPIAR10005, ignoring these images…
Found raw data for 0 images.
Traceback (most recent call last):
File “/usr/local/cryosparc/cryosparc-compute/”, line 115, in
dataset = dataio.dataset_factory(current_dataset_params, do_cache=False, do_datasign_estimation=False)
File “/usr/local/cryosparc/cryosparc-compute/dataio/”, line 18, in dataset_factory
File “/usr/local/cryosparc/cryosparc-compute/dataio/”, line 80, in filesets_into_dataset
v = dataset[0].ctf_params[k]
IndexError: list index out of range

I read some of the other posts and I thought it might be because I had my configure tab set up wrong and so I tried a number of combinations of Meta Data Files and Image Data files but I still get similar errors.

Any help would be greatly appreciated.


Did you add the example_data directory to the cryosparc bulk store?
Are you sure the downloads of the examples completed?

Yes and Yes

thanks in advance

Hi @JBandassociates,

Can you confirm that on your configure page, you’ve set both:
Meta Data File = example_data/EMPIAR10005/
Image Data File = example_data/EMPIAR10005/empiar10005_trpv1.mrc
and also set the pixel size to 1.2156?