Topaz picking problem

Hi everyone,

Is there anyone have an idea why Topaz extract job only picked particles from left 1/4 area of my image? As shown in the picture, I can see all of the images were picked only left below corner. My cryosparc version is 4.3.1. At first I did the patched motion correction by F-crop 1/2, and I processed the data to almost reached the Nquist resolution, then I decided to redo motion correction job with no F-crop and CTF refinement. After that I tried to pick particles from new processed images, using the Topaz training model I trained on the binned data, this phenomenon happens. I also have tried re-train the Topaz model using particles from the un-bin data, but it still only picked left below corner area. Anything I’m wrong here? Thank you for your suggestions!

clearly a 2-fold binning issue, coordinates only extend 1/2 in each direction. Most likely path to success is to start the process cleanly, with wholly new preprocessing and picking. Alternatively, when you “retrain using particles from un-bin data”, do you also provide it un-bin micrographs to the training?

Hi, the un-bin model I used is imported from another project with similar structure shape. These two datasets are collected from same microscope with same settings. The trained model of another dataset was from the un-bin micrographs. Don’t know why this happens.

Not sure exactly, but I wonder if it is related to this issue: Topaz vs cryoSPARC coordinate wrangling query

Hi @liningsdu and @olibclarke,

I have a feeling this is an issue related to the preprocessed micrographs available to TOPAZ. When you first run topaz train/extract, a preprocessing directory is checked for the presence of downsampled micrographs. If they are present, TOPAZ will skip the downsampling step. When using the two sets of micrographs that are binned differently, did either of you try to specify a new preprocessing directory for TOPAZ so that there are a set of TOPAZ downsampled micrographs that correspond to each set of patch mot corrected micrographs?


1 Like

Problem solved! Yes, it’s about the preprocessing directory of Topaz train job, I deleted it before I run the job and everything works well! Thank you everyone!

1 Like

@liningsdu, good to hear!

1 Like