Topaz installation in Cryosparc 4.1.2

Hi Everyone,
It seems that, following the standard instruction of topaz installation from cryosparc/topaz site does not work. I installed topaz 0.2.4 in miniconda3 environment using the command:
conda install topaz=0.2.4 cudatoolkit=11.4 -c tbepler -c pytorch -c conda-forge
also tried cudatoolkit 11.2
I have RTX3090 with 470 driver.
It seems that there is some mismatch between cudatoolkit and pytorch.
Every time i try to start topaz train i get the following message.

UserWarning: The given NumPy array is not writable, and PyTorch does not support non-writable tensors. This means writing to this tensor will result in undefined behavior. You may want to copy the array to protect its data or make it writable before converting it to a tensor. This type of warning will be suppressed for the rest of this program. (Triggered internally at /croot/pytorch_1675190298929/work/torch/csrc/utils/tensor_numpy.cpp:172.)

Any suggestions
Thank you

Any suggestions from the community regarding the above problem?

Finally solved this issue. Here are the tricks.
Topaz installation command given in cryosparc did not work for me. may be cudatoolkit 11.2 and torch version had some compatibility issue. i used the following command.
conda install topaz cudatoolkit=11.7 -c tbepler -c pytorch -c nvidia
i have RTX3090 card and running on cuda 11.4, as cryosparc does not support cuda 12. the above command installs topaz in a miniconda environment. i am able to get the topaz version after typing “topaz --version”
Thank you


Thank you for posting this! Were you still using python=3.6 for your conda env?