ThreeDSFC job fails v4.1.2

We are trying to run a ThreeDSFC job on cryosparc v4.1.2 using as input the volume and mask resulting from a homogeneous refinement job. We have tried to vary the input parameters of the job but we always receive the same error:

Traceback (most recent call last):
File “cryosparc_master/cryosparc_compute/”, line 96, in
File “/home/lnd/Cryosparc/cryosparc_worker/cryosparc_compute/jobs/fsc3D/”, line 80, in run_fsc3D
results = compute.generate_3dfsc(map_half_A, map_half_B, apix, dthetaInDegrees)
File “/home/lnd/Cryosparc/cryosparc_worker/cryosparc_compute/jobs/fsc3D/”, line 858, in generate_3dfsc
NormalizeShells(nx,ny,nz,kXofR,kYofR,kZofR,inc,retofROutR, retofROutI, n1ofROut,n2ofROut, NumAtEachR, RMax);
IndexError: index 8 is out of bounds for axis 0 with size 8

Does somebody have an idea how to fix this?

Same Error for my ThreeDSFC on v4.1.1.

Hey @Pielhaas and @shuhui, it seems to be a bug within the 3DFSC code itself, and I’m not sure why it’s only showing up now. But we will fix it on our end in a future patch :slight_smile:

Hi @shuhui, @Pielhaas, this should be fixed in the latest patch - let us know if there’s any further issues!

Thanks @kwang - further issues with 3D-FSC in this thread from a while back: 3D-FSC feature request

(see second message re missing stuff in plots)

Thanks for fixing this. There is yet one more issue, the volume does not display in the volume viewer

Thank you, @kwang, we upgrated to the newest version of cryosparc, while still with the same error when run threeDFSC as below.

[CPU: 1.13 GB Avail: 118.07 GB]
Traceback (most recent call last):

  • File “cryosparc_master/cryosparc_compute/”, line 96, in*
  • File “/s0/cryosparc_user/cryosparc_worker/cryosparc_compute/jobs/fsc3D/”, line 80, in run_fsc3D*
  • results = compute.generate_3dfsc(map_half_A, map_half_B, apix, dthetaInDegrees)*
  • File “/s0/cryosparc_user/cryosparc_worker/cryosparc_compute/jobs/fsc3D/”, line 858, in generate_3dfsc*
  • NormalizeShells(nx,ny,nz,kXofR,kYofR,kZofR,inc,retofROutR, retofROutI, n1ofROut,n2ofROut, NumAtEachR, RMax);*
    IndexError: index 8 is out of bounds for axis 0 with size 8

Have you applied the 230302 patch? You can query the patch level by running:
cat /s0/cryosparc_user/cryosparc_worker/patch