Template-picked particles causing issues during 2nd iteration of 2D classification


I am re-posting this since I wasn’t able to resolve the issue after the first post.

I am experiencing an issue with 2D classification of particles that were template-picked. The particles were picked, curated, then 2D classified using all default values (J106).

After weeding out the really bad classes, I was left with J111.

I attempted to do a second round of 2D classification. As the particles are small (~210 A on longest axis), I increased the number of iterations to 40 and the batch size to 400. These are the only parameters that I changed. The second round of 2D classification is shown in J112.

This is the first time I have had this issue and it only happens with template-picked particles. Within the past week, I did several rounds of 2D classification with blob-picked particles and never ran into this issue. Also, I have used cryosparc in the past with a template picker and not had this issue, so I am not sure what is going on.

I have tried enforcing a tighter circular mask and skipping the ‘inspect particle picks’ job, but neither fixed the issue. I have had no issues when using particles that were picked with the blob picker.

Do you have any advice?

Non-expert advice here, but…

  1. Don’t change the # iterations and batch size. Just do a default 2d classification (not cloned from any previous job), using J111 as the input. See if that gives the same result. If it gives normal results, that tells you that something is wrong with the parameters in J112, not the particles. If it gives the same weird results, that’s deeply weird and suggests a possible bug, which you should report in the bug-reporting category.

1a. Further trouble shooting: If a normal 2D classification a normal result, try changing each parameter one at a time, # iterations vs batch size, to determine whether the fault arises with one parameter or the other, or only in combination.

  1. Look very, very carefully through the parameters in J112. Print the parameters from J106 and J112, and go through them line by line with a ruler and pen to compare. I’ve gotten weird results before when I inadvertently changed something, and I find it can be hard to spot exactly what is different scanning through on the computer, which is why I suggest printing it.

  2. I was going to say that it looks like your circular mask is too big, but I see your comment that a tighter mask didn’t help.

  3. The black bar at the side of each class is weird looking. Are these particle picks all near the edge of the hole, and that’s what you’re seeing, and maybe that is throwing off the particle alignment? Where I do see a vague particle in the classes, it’s at the very edge of the mask, which suggests the particle picks are very off-center, and that might be the difference between the blob-picker and the template picker.

Update: See my reply in your original thread: 2D classification of template-picked particles causing issues