Syntax error near unexpected token `fi'

While updating to 4.3.1, I got this error just after the instructions to update the worker manually and just before the update ended:

/sc/arion/projects/WL/cryosparc/software/cryosparc/cryosparc_master/bin/cryosparcm: line 2206: syntax error near unexpected token `fi’

Script seems to be OK, though.

What where CryoSPARC version and patch when you ran
cryosparcm update?
To check whether the error is safe to ignore, you may want to run a validation job.

I had the same thing when I forgot to remove CUDA from $PATH and $LD_LIBRARY_PATH before updating to 4.3.1 on one system.

Removing CUDA from both, running forcedeps then install-3dflex and everything is working happily.

4.2.1 Not sure of the patch level…It did not install properly, website will not accept connections.

Did you ensure a complete shutdown of CryoSPARC before the update?
You may want to check

  1. cryosparc_master/run/update.log for update errors.
  2. the command_core log for startup errors
  3. the output of
    ps -e -ouser,pid,ppid,start,cmd | grep -e cryosparc -e mongo | grep -v grep
    for “stale” CryoSPARC master processes

Rolled back to 4.2.1 and it started running perfectly. I noticed that there was an old job that ended but cryosparc keeps looking for it and getting no response. Filling up the logs too. Could that have caused the problem?

Please can you post a log excerpt that shows

  1. project and job UIDs
  2. the actual error message and context

Looks like the job was cancelled with a bkill outside of cryosparc.
Would a set_job_status to killed cause any other problems?

Project_uid = P1
Uid: J914

Error message (repeats many times):
^[[0mSending command: /hpc/lsf/10.1/linux3.10-glibc2.17-x86_64/bin/bjobs -l 88634528^[[0m
^[[0mSending command: /hpc/lsf/10.1/linux3.10-glibc2.17-x86_64/bin/bjobs -l 88634528^[[0m
^[[0mSending command: /hpc/lsf/10.1/linux3.10-glibc2.17-x86_64/bin/bjobs -l 88634528^[[0m

Response is: Job <88634528> is not found

I managed to get rid of the error message by using db.job.update_one to explicitly mark that job as killed. Completely shut down Cryosparc but still get:

Done updating all worker nodes.
If any nodes failed to update, you can manually update them.
Cluster worker installations must be manually updated.

To update manually, copy the cryosparc_worker.tar.gz file into the
cryosparc worker installation directory, and then run
$ bin/cryosparcw update
from inside the worker installation directory.

/sc/arion/projects/WL/cryosparc/software/cryosparc/cryosparc_master/bin/cryosparcm: line 2205: syntax error near unexpected token `;;’
[wackerlab-cryoadmin@lc03g01 run]$

This is in the tensorflow check section. Should I be updating on a gpu node?
Anything else to check?


This might be a harmless error if the command you ran
cryosparcm update
on a CryoSPARC v4.2.1 instance and lc03g01 is the instance’s master node.
As the message indicates, in the cluster case, you may need to follow up with an update of the cryosparc_worker/ installation(s).
I would run the cryosparcw update command mentioned in the instructions on a node with a functional nvidia GPU and driver.

Please can you provide more details.

Latest attempt worked. Still got the error but jobs were accepted and ran.

Thanks for all your help


1 Like

In case job is still creating log entries, yo may want to try to Kill Job, then Mark Job as Complete in the web browser UI. If these options are not available or fail to resolve the problem, you may run

cryosparcm cli "set_job_status('P1', 'J914', 'killed')"