Symmetry problem during NU-refinement

Hi all,

I’m currently working with a dimer protein, that exposed a C2 symmetry.
Today I faced a weird issue that I’ve never encountered before.

After an extraction, I ran a NU-refine with C2 symmetry. Everything went well.
Then, I ran an heterogeneous refinement with C2 symmetry enforced, again, no problem.

But after this heterogeneous refinement, I started to run another NU-refinement, and this time it failed systematically with this error :

[CPU:  681.8 MB]
Traceback (most recent call last):
  File "cryosparc_master/cryosparc_compute/", line 96, in
  File "cryosparc_master/cryosparc_compute/jobs/refine/", line 232, in
  File "/net/cemaster/data/software/cryoSPARC/V2/cryosparc2_worker/cryosparc_compute/util/", line 82, in __call__
    return self[args]
  File "/net/cemaster/data/software/cryoSPARC/V2/cryosparc2_worker/cryosparc_compute/util/", line 85, in __missing__
    ret = self.f(*key)
  File "/net/cemaster/data/software/cryoSPARC/V2/cryosparc2_worker/cryosparc_compute/", line 70, in get_symmetryop
    assert False, 'Missing symmetry file or unrecognized symmetry type: {0}'.format(symstr)
AssertionError: Missing symmetry file or unrecognized symmetry type: C2

What I don’t understand is that I ran dozens of homo refine or NU-refine before with C2 symmetry without any problem.

If I try to run another NU-refinement with the first one (just before heterogeneous refinement job) as a reference, it fails as well. The same one with C1 symmetry runs fine though.

The problem seems to be part of the heterogeneous refinement job or perhaps the extraction job, because all my NU-refine before this job works well with C2 enforced.

Any help will be welcomed.


@KevinM Could a non-printing character have found its way into the definition of the params_spec.multirefine_symmetry parameter? Please can you post a screenshot of the relevant portion of the job doc (Metadata|Data)?

Hey wtempel,

Thank you so much for your help.
Indeed, a non-printing character was introduced. It was a space character just after “C2”

I join the screenshot of the log for your information.
Again thanks !

Capture d’écran 2023-08-28 à 15.21.36