Symmetry alignment problem


I’m having a symmetry issue recently in refinement works and it seems that it has already been registered in 2017 - How does cryosparc align to symmetry?

I think this problem has not been solved yet.

I try to change the axis by chimera and reimport it, but the refinement continue to produce incorrect results.

Is there any way to solve this problem?

Thank you :slight_smile:

Hi, when you re-import, do you turn off symmetry alignment? If the axis is already pre-aligned in Chimera and you turn off symmetry alignment then you should be okay, but yes it is still an issue


Found this while searching forum for exactly this problem, so I’ll second this thread.

Seconding also olibclarke’s call in the earlier thread for the ability to permute axes as a volume tool. (Can be done with, but I haven’t gotten that working yet.)

My case: I have C3 particles, which show mostly side views with the particle symmetry axis parallel to plane of grid, but which definitely show some top views too, looking down particle symmetry axis. Ab initio refinement (no symmetry) puts the particle symmetry axis onto cryoSPARC’s X-axis, rather than Z.

My (non-expert) work-arounds to get the symmetry axis onto Z-axis:
1.) Run multi-class ab initio refinement with symmetry imposed. Seems necessary to have multiple classes or else it can’t “find” the right orientation.
2.) Turn the map in Chimera, then import back into cryoSPARC.

Chimera script for option 2 follows:
open yourMap.mrc;
open yourMap.mrc; #two copies necessary
turn y 90 models #1; #modify as needed to get symmetry axis parallel to Z
vop resample #1 onGrid #0; #this step is why you need 2 map copies
volume #2 save filePath/outputMap.mrc

1 Like

@olibclarke @rj.edwards

It was so helpful!
I’ll give it a try

Thank you very much :smiling_face_with_three_hearts: