Standalone, WSL cryoSPARC v4, ssh connection is refused


I’ve been unsuccesfully trying to set up standalone cryoSPARK v4 in my PC with Windows11 by WSL.
I installed cryoSPARC and (maybe) could connect it with the machine. It went succesfully running jobs such as “Import Movies”, “Motion Corr”, “Particle Picking” etc… but “2D Classification” failed with an error

Failed to launch! 255 ssh: connect to host HOSTNAME port 22: Connection refused

I tried to somethig like ssh-keygen, opening the port, and confirming Firewall was inactivated. Is there anything I can try?

Thanks in advance

↓entire log of 2D Class
License is valid.
Launching job on lane default target WORKERNAME ...
Running job on remote worker node hostname HOSTNAME Failed to launch! 255
ssh: connect to host HOSTNAME port 22: Connection refused

Mismatches between the output of
hostname -f, the CRYOSPARC_MASTER_HOSTNAME value defined in
and the "hostname": value from
cryosparcm cli "get_scheduler_targets()"
might trigger job submission via ssh even on a single workstation CryoSPARC instance.
The output of hostname -f might change depending on WSL configuration and/or network environment.
A possible workaround for a single workstation instance is to ensure CRYOSPARC_MASTER_HOSTNAME matches the target’s "hostname": and also the value of CRYOSPARC_HOSTNAME_CHECK. Specifically, one may, when no CryoSPARC jobs are scheduled or running:

  1. cryosparcm stop
  2. edit /path/to/cryosparc_master/ to define:
  1. cryosparcm restart
  2. record the output of
    cryosparcm cli "get_scheduler_targets()"
    This information may be needed for possible customization of your worker configuration.
  3. remove the current worker definition with (guide)
cryosparcm cli "remove_scheduler_target_node('<current-target-hostname>')"
  1. add a modified worker definition back to the CryoSPARC database ((assuming no particle cache device should be configured and a CRYOSPARC_BASE_PORT 39000, guide)
/path/to/cryosparc_worker/bin/cryosparcw connect --master --worker --nossd --port 39000

Another option is to configure ssh with key-based authentication, as you mentioned.
Please let the forum know if you succeed in running a complete reconstruction in WSL.

1 Like

Thank you for your reply and I succeeded in running cryoSPARC jobs such as classifications and 3d reconstructions with WSL. I changed the configuration as your direction.

I have not tried some kind of jobs after reconstruction but I believe it works all of them. Thanks.

1 Like

Hello @wtempel,

It seems that I have the similar issue.

So I edited the file.

And it currently helped.

Thank you!