Standalone installation fails at the worker stage


I just tried installing a standalone cryoSPARC v3.3.2 on a new workstation running Rocky 8.6. The cryosparc_master installed fine, but then the installation failed at the cryosparc_worker stage. Here is the error message I got:


  The installer will now download, install and connect the worker
  package on this machine. The worker package will allow cryoSPARC
  to run compute jobs.


 Starting cryoSPARC...

Starting cryoSPARC System master process..
CryoSPARC is not already running.
database: started
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/opt/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/site-packages/pymongo/", line 1915, in list_database_names
    for doc in self.list_databases(session, nameOnly=True)]
  File "/opt/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/site-packages/pymongo/", line 1896, in list_databases
    res = admin._retryable_read_command(cmd, session=session)
  File "/opt/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/site-packages/pymongo/", line 756, in _retryable_read_command
    _cmd, read_preference, session)
  File "/opt/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/site-packages/pymongo/", line 1461, in _retryable_read
    read_pref, session, address=address)
  File "/opt/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/site-packages/pymongo/", line 1278, in _select_server
    server = topology.select_server(server_selector)
  File "/opt/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/site-packages/pymongo/", line 243, in select_server
  File "/opt/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/site-packages/pymongo/", line 200, in select_servers
    selector, server_timeout, address)
  File "/opt/cryosparc/cryosparc_master/deps/anaconda/envs/cryosparc_master_env/lib/python3.7/site-packages/pymongo/", line 217, in _select_servers_loop
    (self._error_message(selector), timeout, self.description))
pymongo.errors.ServerSelectionTimeoutError: localhost:39001: [Errno 111] Connection refused, Timeout: 20.0s, Topology Description: <TopologyDescription id: 62a0b590a5ac5196ba99eb5b, topology_type: Single, servers: [<ServerDescription ('localhost', 39001) server_type: Unknown, rtt: None, error=AutoReconnect('localhost:39001: [Errno 111] Connection refused')>]>

I made sure the port range 39000-39010/tcp is open before running the installer. I also tried with CUDA 11.2.0 (I had initially tried with CUDA 11.2.2, maybe this one is too new, since the documentation specifies a CUDA version <= 11.2), but got the same error.

I would appreciate any help with this.
Thank you in advance!

Also, just after this installation failure, this is what cryosparcm status reports (only the database is running):

CryoSPARC System master node installed at
Current cryoSPARC version: v3.3.2

CryoSPARC process status:

app                              STOPPED   Not started
app_dev                          STOPPED   Not started
command_core                     STOPPED   Not started
command_rtp                      STOPPED   Not started
command_vis                      STOPPED   Not started
database                         RUNNING   pid 92774, uptime 17:17:25
liveapp                          STOPPED   Not started
liveapp_dev                      STOPPED   Not started
webapp                           STOPPED   Not started
webapp_dev                       STOPPED   Not started

*** command (http://022-031-LNX.cbi.local:39002/api) did not reply within timeout of 300 seconds, attempt 1 of 3
*** command (http://022-031-LNX.cbi.local:39002/api) did not reply within timeout of 300 seconds, attempt 2 of 3
*** command (http://022-031-LNX.cbi.local:39002/api) did not reply within timeout of 300 seconds, attempt 3 of 3
An error ocurred while checking license status
Could not get license verification status. Are all CryoSPARC processes RUNNING?

Looks like I found the solution, even though I am not sure I understand the problem.

I had opened the ports on the public zone, because this is what worked at my previous workplace, using the following commands:

sudo firewall-cmd --zone=public --add-port 39000-39010/tcp --permanent
sudo firewall-cmd --reload

The network at my current workplace must be configured differently, because I now had to open these ports on the home zone for the installation to finally work (replace the zone name in the command above). I don’t understand this concept of zones, so I don’t understand the problem. But this seems like a correct solution.