Some jobs remain showing without coordinates

issue_recorded

#1

Hi All,

All of a sudden, I keep getting an error message dropping down from the top of the window saying “some jobs remain showing without coordinates!” when I try to add a job to the queue. I feel like I am missing something simple, but has anybody encountered this issue before?

Cheers,
Stefan


#2

Hi @stefan,

This is a warning related to the tree view. It just means one of your jobs weren’t plotted in the tree, but is still visible.


#3

Hi @sarulthasan,

Thank you for your feedback. I am struggling to figure out what jobs are not plotted in the tree in my case.

The warning is precluding me from starting new jobs, as the parameter/input pane on the right side is not accessible once the warning comes up.

I’ve tried e.g. importing particles from a “stuck” project into a new one through setting up a 2D classification job, and I get the following (generic python?) message: ‘NoneType’ object has no attribute ‘getitem’.

Any ideas on what the underlying issue might be?

Alternatively, assuming it is not a corrupt database issue, can I re-install Cryosparc2 and re-import the data/jobs to restore the projects to their current states?


#4

Hi @stefan,

Is it possible if you can provide some screenshots of the situation?


#5

Hi @sarulthasan,

Please find a screenshot of the warning… not sure how informative it is: please let me know if there is anything else I can screeshot or look into to get an error log.

Cheers,
Stefan


#6

Hi, I also experienced this issue and it has spontaneously resolved.
After clicking the job type in Job Builder, the “some jobs remain…” error message pops up at the top of the screen and the dialog box does not open on the right, so there is no way to drag items into the inputs. This lasted for about 12 hours and persisted after restarting cryosparc and was present in both Firefox and Chrome. All of a sudden the error stopped popping up and I am able to start new jobs. I have no idea what fixed the issue.


#7

Hi @user123,

We’ve identified the issue and will work to resolve it for an upcoming release.

Thanks,
Suhail


#8

That’s great. Is there any known workaround to resolve the issue in the short term when it does appear?


#9

Hi @user123,

Unfortunately you’ll need to wait until the update goes live; there isn’t a way to suppress the notification on your end.

- Suhail


#10

Hi @sdawood

Has this issue been resolved? I just experienced the exact same thing in the latest cryosparc 2.9 release.

Best,
Omid


#11

I am having the same problem with 2.9 - are there any recent updates to overcome this? Cryosparc is unusable with this error!


#12

Hi

Ive just got the same error message in new version 2.9. However it was already one day and it didnt resolve by itself. Is there a way to deal with it and continue working on project?


#13

Hi everyone,

This message appears under some edge cases with our tree layout algorithm - after testing out many cases we still haven’t been able to reproduce this problem ourselves. However, we have now suppressed the message from occurring. It will be available for everyone in the next release (likely v2.10).

Just to confirm, this shouldn’t render any projects unusable. You can still continue processing jobs (and even use the card view) without any issues.

Thanks and sorry for the inconvenience,
Suhail